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Read me

1. This manual intends among other things to let you know the structure

of ArcView GIS software, know how to make use of the menus,
buttons and tools associated with the software and know how to add

existing data and create new data, manipulate your data and compose a
map.

. Each of the exercise in this manual is divided into steps. You are

expected to read the contents of each step and do exactly what you are
asked to do.

. Each exercise has an introduction that explains what the goals

of the exercise are and what tasks you can expect to
accomplish.

. Whenever you encounter problem in executing any step call the

attention of the instructor to the problem. Do not leave any step un-
done.

5. Name of object you’ll use to carry out an action is bolded.

6. We include self-test exercises for you also. This would enable self-

appraisal. So, endeavor to attempt all the tests.
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Exercise 1
Working with ArcView GIS

1.1 Basics of ArcView GIS

Welcome to the first exercise in basics of ArcView. The goal of this exercise is to
introduce you to ArcView and its capabilities. You'll examine ArcView by opening an
ArcView project and exploring each of its components.

Estimated time to complete: 10 minutes

Step 1 Start ArcView

Click Start, then Programs, then select ArcView GIS Version 3.1 (or higher) or
ArcView GIS Virtual Campus Edition in the ESRI programs group. If the Welcome to
ArcView GIS dialog appears click Cancel.

Step 2 Examine the interface

At the top of the ArcView window is a menu bar with four pulldown menus: File,
Project, Window, and Help. These menus are available when the Project window
(the smaller "Untitled” window within the ArcView window) is active. Below the
menu bar is the button bar with two buttons, Save and Help. Below the button bar is
the toolbar. It doesn't contain any tools yet. Move your mouse pointer over the
buttons. The function of each is displayed in the status bar at the bottom of the
ArcView window.

Step 3 Open a project

Next, from the File menu, choose Open Project. In the Open Project dialog,
navigate to the introavibasics\lesson01 folder created when you downloaded the data
for this lesson. Click on 101_ex01.apr (the project for Exercise 1 of Lesson 1) from
the left scrolling list. Click OK. ArcView projects always have an “.apr” extension.

Step 4 Select multiple views

Currently, the Views icon is highlighted. The New, Open, and Print buttons at the
top of the window let you create new views, open existing views, and print a view
that's highlighted in the list. The buttons at the top of the window will change for each
document type. On the right side of the window, you see the names of the two views
currently contained in this project. You want to work with both views at the same
time so you need to highlight both of them. Hold down the Shift key and click on the
Population Density view. Now both views in the list are highlighted.

Step 5 Open the views

Next, open both views by clicking the Open button at the top of the Project window.
The two view windows open and ArcView's interface (menus, buttons, and tools)
changes to reflect the view document type. You can tell that the Population Density
view is active because its title bar is highlighted and its window is in the foreground.
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Step 6 Make a view active

Each theme in the Population Density view has a title and information that describes
what the theme shapes represent. The World Cities theme represents cities of the
world. The Countries by Population Density theme shows countries. (Notice that
some of the countries display in yellow. This indicates that they've been selected as a
separate group.) In the background is a theme showing a grid of latitude and
longitude. Click on the Gross National Product title bar. It becomes the active view.
Again you see a theme of world cities, a theme of countries, and a theme of latitude
and longitude; however, in this view, the countries are shown according to their gross
national product (GNP).

Step 7 Close a view

Each of these views displays the world differently. In ArcView, you can display the
same source data differently by changing the properties of the views. Close the Gross
National Product view by clicking on the icon in the upper left corner of the
Gross National Product window and choose Close from the menu. The view
window closes.

Step 8 Open a theme attribute table

Now you'll look at the attributes that are linked to the features in the Countries by
Population Density theme. Notice that the gray area containing the name and the
symbols for the Countries by Population Density theme appears raised, indicating that
this theme is active. Open the table for the active theme by clicking the Open Theme

Table button on the View button bar. Use the scroll bar at the right of the table
and scroll down until you see the selected records (highlighted in yellow). You may
want to widen the table window to see the fields better.

Step 9 Promote the selected records

Some of the African countries and their table records are highlighted in yellow. You
can't see any of the selected table records unless you scroll down the table and even
then, you can't see all the selected records together as a group. With the Table window

active, click the Promote button (or, from the Table menu, choose Promote).
ArcView moves the highlighted records to the top of the table.

Step 10 Examine the other attributes

View the rest of the theme's attributes by scrolling to the right in the table. Notice that
the table contains attribute information on growth rate and the total population for
1980 (Grw_rate80, Tot_pop80 for each country.

Step 11 Open a chart

Next, you will open a chart showing the birth and death rates for the highlighted
African countries. Click on the Project window title bar to make it active. Click on
the Charts icon. The Birth/Death Comparison chart is highlighted in the list. Click
the Open button. The Birth/Death Comparison chart is now the active document, and
AThVims interface changes to display the menus, buttons, and tools you use to work
with charts.
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Step 12 Open a layout

The chart is covering up the Project window, so bring the Project window to the front
by choosing less01_1.apr from the Window menu. Next, click on the Layouts icon to
display the list of layouts in the project. Click the Open button to display the
Population Growth Rates layout. The Population Growth Rates layout opens and
ArcView's interface changes to display the menus, buttons, and tools you use for
working with layouts. This layout contains the Population Density view and its
symbols, the Countries by Population Density table, the Birth/Death Rates chart, and
additional graphics and text. Note: If you don't see the chart and table on the layout,
make sure that both the chart and table are open in your ArcView window. Close the
Layout, then reopen it.

Step 13 Save the project

From the File menu, choose Close All. Again from the File menu, choose Close
Project. When asked if you want to save changes to the project click Yes. Oaly the
main ArcView window remains open and active. You've now seen an ArcView
project and some of the documents it can contain (views, tables, charts, layouts).
You've also seen that each document type has its own interface containing menus,
buttons, and tools. In the lessons that follow, you'll perform specific GIS tasks using
views, tables, charts, and layouts in a project. After you've completed all the lessons,
you'll be ready to tackle your own ArcView project.

Self test

(1) AscView project components (such as views and tables) are called:
c Files

c Documents

E aprs

C Archives

(2) Views display geographic data organized as:

c Tables

c Layouts

c Charts

C Themes

(3) How do make a view active?
c Open an attribute table

e Click Help button

e Add it to a layout

L Click its title bar
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(4) In ArcView the available menus, buttons, and tools are the same for a view as they are for
a table.

e True
E False

(5) When you want to create a cartographic quality map in ArcView, you work with this
ArcView document

C Layout
C Chart
C Link

e Script

Getting data into ArcView

1.2 Add themes to a view
In this exercise you will add themes onto a view and you would examine other
properties of a theme.

Estimated time to complete 15 minutes

Step 1 Start ArcView

If ArcView is not running, start ArcView. If the Welcome to ArcView GIS dialog
appears, click Open an existing project and click OK. If the dialog doesn't appear or
if ArcView is already running, from the File menu, choose Open Project. Navigate to
the introav\basics\lesson02 folder and open the ArcView project LO2_ex0l.apr.
Because no views have been created yet, you see an empty Project window.

Step 2 Create a new view

With the Views icon highlighted, click New button (or, double-click the Views icon).
A new, empty view window, Viewl, opens. You can resize and reposition this
window anytime you need to. The gray area on the left side of the view is the Table of
Contents. It's empty now, but when you add a theme to the view, the theme's name,
the symbol used to draw it, and a check box indicating whether it's currently displayed
will appear in the Table of Contents.

Step 3 The Add Theme dinlog

From the View menu, choose Add Theme. The Add Theme dialog displays. Navigate
to the lesson02 folder in your exercise data folder. ArcView lists the geographic data
sources available in this directory. You will see four data sources: boundary-outline,
drainage, rainfall, and settlements,



Step 4 Add a theme to the view document

Now, you'll add a theme from the boundary-outline data source. Double-click
boundary-outline to add it to the view as a theme. The theme's name and a symbol
appear in the view Table of Contents. Your view now contains one theme, boundary-
outline. By default, ArcView doesn't draw the theme. To display the theme, turn it
on by clicking its check box -!. ArcView draws the features in the theme (lines)
using the current symbol. When you add a theme to a view, ArcView randomly
assigns a color to the theme. Therefore, the boundary-outline theme may be a
different color in your view. Tumning a theme on simply allows it to display.

A theme doesn't have to be turned on for you to perform ArcView operations on it,
and turning a theme off doesn't remove it from the view.

Step 5 Add other themes to the view document
Next, you'll add themes based on the drainage, rainfall, and settlements data sources.

Click the Add Theme button @ to display the Add Theme dialog again. Navigate
to the lesson02 folder. You see the same list of data sources.

Step 6 Select several themes in the Add Theme dialog
Click on the rainfall. Then, hold down the Shift key and click once on drainnage
and once on settlements. All three data sources are highlighted.

Step 7 Add the themes and turn them on

Click OK to add these three themes to the view. Click on the check box — next to
each name to draw each theme. Your view now contains three additional themes: the
drainage theme containing line features, the settlements theme containing points, and
the rainfall theme containing polygons.

Step 8 Select an image data source

Click the Add Theme button. Navigate to the lesson02 folder. Click the dropdown
arrow for the Data Source Types list then click Image Data Source. The aerial
photograph image source appears in the list on the left side of the dialog. The .tif
ending indicates a type of image format.

Step 9 Add the image to the view and turn it on

Double-click syria.tif. ArcView adds this satellite image to the view. Click the check
box for the syria.tif theme to tum it on. ArcView draws the photograph as a black and
white image in the view. The image draws on top of the other themes. That's because
ArcView first draws the theme listed at the bottom of the Table of Contents then
draws each theme listed above it. Thus, the syria.tifl theme draws last. You can
change the drawing order by dragging themes up or down in the Table of Contents.

Step 10 Make the image theme active
You want the image to display in the background (behind the other themes) so you'll
drag it to the bottom of the Table of Contents. To do so, you must first make the
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syria.tif theme active. Click once on the syria.tif theme in the Table of Contents to
make it active. Now it appears raised in the Table of Contents.

Step 11 Change the theme draw order

Click the syria.tif theme's name (or the raised gray area surrounding it), hold down
the left mouse button and drag to the bottom of the Table of Contents, then release the
button. ArcView draws the image theme first this time then draws all the other themes
on top of it.

Step 12 Close the project

You'll close the project without saving. From the File menu, choose Close All. Again
from the File menu, choose Close Project. Click No when you're prompted to save
your changes. You can see how easy it is to create a view and add themes to it from a
variety of data sources. Once you've added themes to a view, you can change the
appearance of the view by turning themes on and off and by moving themes up and
down in the Table of Contents.

Self test

(1) In ArcView, every theme, no matter the data type, must have an attribute table.

(2) The order of the themes in the Table of Contents does not affact their display within a
View.

c True
c

False

(3) ArcView supports only one image format.
e True

c False

{4) in a theme attribute table, each record {or row) represents a:

¥ Column

e Graphic element

c Feature

c Chart

(5) In which field of a theme attribute table can you find the feature type of a theme?
e Shape

E 1y
CID

10
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(6) What is true about the order of the themes in the TOC

C The order changes the speed of display.

c The ordet ensures that themes are alphabetical for better readabllity
C A theme must be at the top to be active

c Themes are displayed in order from top to bottom.

Which feature type is stored as a pair of x,y coordinates?

c Point

c Polygon

c Image

c Line

Which one of the following ArcView functions can you use with satellite image data?
c
e Identify

c Image tegend Editor
c Open Theme Table

Image Query Builder

1.3 Understand theme tables

When you add a theme based on a feature data source, a theme attribute table (or
simply theme table) is also added to the project. A theme table contains descriptive
information about the features in the theme. The theme table is formatted in rows and
columns, called records and fields, respectively. Each field contains all the values for
an attribute; each record represents a single feature in the theme. Because attributes
are linked to the features they describe, you can access them by clicking on a feature
in the view, or you can find a feature in the view by clicking on its record in the table.

Estimated time to complete: 15 minutes

Step 1 Open the project
Start ArcView if it is not already open. From the File menu, choose Open Project
and navigate to the introav\basics\lesson02 folder and open L02_ex02.apr.

Step 2 Make a theme active

Click on the geology name or its legend symbol in the Table of Contents to make it
active. The theme appears raised in the Table of Contents.

11



Step 3 Open the theme table

Click the Open Theme Table button on the View button bar. A table window
opens containing the attributes of the geology theme. When the table opens, you see
the first five fields: Shape, Area, Perimeter, Type_dep and Geol_time. The Shape
field tells you the type of feature (i.e., point, line, or polygon) the theme represents.

The Shape field is created by the system. You cannot edit it.

The table also contains geological formations found in Syria and the geological time
of deposition. To see the fields, using the scroll bar at the bottom of the table, scroll to
the right.

Step 4 Resize and reposition the view and table documents

Make Viewl active by clicking on its title bar. Move it to the upper left corner of the
ArcView window then resize it so that it fills the upper portion of this window. Make
the Attributes of geology table active. Move it to the lower left corner of the ArcView
window then resize it so that it fills the lower portion of this window.

Step 5 Use the Select Feature tool

Now you'll use the Select Feature tool to select the formations at any part of the
view. Make the view active by clicking on its title bar. On the View toolbar, click the

Select Feature tool and then click on any part of the view. The formation
highlights in the view and its record highlights in the table. ArcView scrolls the table
so the highlighted record displays at the top of the table.

Step 6 Select more than one feature

The first item is selected. Now you want to select for more areas. Hold down the
Shift key, and then click on any other part of the view you want. ArcView selects and
highlights the buildings.

Step 7 Promote the selected theme attribute table records to the top
Because the table is large, you can't see all of the highlighted records. To see the
highlighted records together in the table, you'll use the Promote function. Make the

table window active by clicking on its title bar. Click the Promote button on the
Table button bar. The highlighted records display at the top of the table.

Step 10 Close the project

Close the project without saving. From the File menu, choose Close Project. Click
No when you're prompted to save your changes .By selecting features in a view, you
can access their attributes in the theme table. You'll learn other ways to select features
and access information about them later in this course.

12
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Displaying themes
1.4 Display features based on their attributes
Estimated time to complete: 20 minutes

Step 1 Start ArcView and open the project

If necessary, start ArcView. From the File menu, choose Open Project and open
introavibasics\lesson03\L03_ex01.apr.When the project opens you see a view with
one theme, Regions. Notice that, by default, ArcView assigns the same color to all the
regions. You'll use the Legend Editor to display the regions based on population.

Step 2 Open the Legend Editor

Double-click the Regions theme in the Table of Contents to display the Legend
Editor. The Theme dropdown list displays the name of the curmrent theme,
Regions.shp. The Legend Type field shows that every feature in the theme is
displayed with a single symbol

Step3 Select a legend type

Click on the Legend Type down arrow and select Unique Value. Notice that the look
of the Legend Editor has changed; it displays new choices that apply only to the
Unique Value legend. Each feature with a unique attribute value will be represented
by a unique symbol in the Symbol column. There are no symbols shown because you
haven't yet selected an attribute to symbolize.

Step 4 Select a values field

Click on the Values field and scroll down in the list until you see Pop_94, then click
on it. Now each county has a unique symbol in the Symbol column. The Value
column lists the Pop_94 value for each region. The Count column tells you how many
counties each symbol represents.

Step 5 Apply changes made in the Legend Editor

Click Apply. If necessary, minimize the Legend Editor or move it out of the way so
you can see the view. Each county now has its own symbol because each has a unique
population value. Looking at this map, you decide that grouping the counties into
classes would be better for your presentation.

Step 6 Change the legend type

If necessary, restore the Legend Editor. This time, choose Graduated Color from the
Legend Type dropdown list. The Legend Editor shows no symbols in the symbol
column yet; the Graduated Color legend requires that you choose an attribute to
classify. It divides the counties into groups based on their attributes. It then assigns
colors in graduated shades to the symbols for the classes.

13
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Step 7 Select a classification field

Click the Classification Field down arrow. Scroll down and click Pop_94 to select it.
Once you select an attribute, ArcView applies a defauit classification method, called
Natural Breaks, to divide the counties into five classes. (You'll leam how to change
the classification method and number of classes later in the exercise.)

Step 8 Use a differeat color scheme

Select Green monochromatic from the Color Ramps dropdown list.

The symbols for the five classes graduate in color from light green (for regions with
the lowest population) to dark green (for regions with the highest population). This is
called a color ramp.

Step 9 Apply your changes
Click the Apply button. The view now has a different symbol for each of the five
population classes. The color ramp makes it easy to see the population distribution.

Step 10 Work with the Dot legend type

Now you'll loock at some of the other legend types to see how they display the
Population data. In the Legend Editor, select Dot from the Legend Type dropdown
list. The Legend Editor shows a Density Field, where you choose the attribute for
density calculations. It also has a Dot Legend field, used to specify how many people
will be represented by each dot.

Step 11 Select a Density Field

From the Density Field dropdown list, select Pop_94. Click the Calculate button.
ArcView calculates the number of people each dot will represent and puts this value
in the Dot Legend field. ArcView takes the size of the window and the screen
resolution into account, so the value it calculates may vary based on your system’s
configuration. Click Apply. ArcView creates a dot density map in the view.

1.5 Classify features

In the previous exercise, you worked with the Legend Editor to change legend types,
but ofien you may also want to change the number of classes or the way the classes
are divided. Changing classes can affect the way data appears and how it is
interpreted, so it's important to choose a classification method carefully. In this
exercise, you will divide a group of regions into high, medium, and low population
classes. You'll create three classes using different classification methods to see how
the map representing region population changes.

Estimated time to complete: 15 minutes
Step 1 Start ArcView and open the project

If necessary, start ArcView. Open introavibasics\lesson03\L03_ex02.apr.
You see a view of the Regions theme with no classification applied.

14
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Step 2 Open the Legend Editor

In the view Table of Contents, double-click the Regions theme to open the Legend
Editor. Choose Graduated Color from the Legend Type dropdown list. Choose
Pop_94 from the Classification Field dropdown list. By default, ArcView creates five
classes using the Natural Breaks method. You want oaly three classes, however, and a
different classification method.

Step 3 Change the classification type

Click the Classify button. The Classification dialog is displayed. Choose Quantile
from the Type dropdown list and 3 from the Number of classes dropdown list. Click
OK. The Classification dialog disappears and you're returned to the Legend Editor.

Step 4 Apply your changes

In the Legend Editor, click Apply. You can see that the regions have been evenly
divided into three classes. The population range of the three classes varies widely,
however.

Step 5 Select a different classification type
Click the Classify button in the Legend Editor. In the Classification dialog, choose
Equal Interval in the Type dropdown list.

Step 6 Apply your changes

Click the Apply button in the Legend Editor then close the Legend Editor. This time,
ArcView divided the entire population range of the regions into three classes that each
has an equal range. The number of regions in each class varies, but the intervals
between high and low values in the classes is the same.

Step 7 Close the project

Close the project without saving. From the File menu, choose Close All. Again from
the File menu, choose Close Project. Click No when you're prompted to save your
changes. You've now seen how to change classification methods to display your data
in different ways.

1.6 Symbolize themes

You've seen how classifying features can change the way a map displays. Now you'll
leam how to change the symbols that represent features. The Legend Editor and
Symbol Window allow you to change the color, size, pattern, and other properties of
map symbols. In other exercises, you've classified the regions based on population.
You now want to change the colors and symbols used in the map.

Estimated time to complete: 15 minutes

15
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Step I Start ArcView and open a project

If necessary, start ArcView. Open introavibasics\lesson03\L03_ex03.apr. When the
project opens, you see a view with three themes: a point, a line, and a polygon
theme. The Regions.shp theme is already classified using the Equal Interval method
and a blue-green monochrome color ramp. The Road-network.shp theme is a line
theme in which each road has been classified. You want to make the map more
informative and attractive by changing the symbols and colors used to display the
features in each theme.

Step 2 Open the Marker Palette

You can change the color, size, and symbol for any feature in a theme by editing the
symbol in the Legend Editor and Symbol Window. In the view Table of Contents,
double-click the Towns theme to display the Legend Editor. Double-click the Towns
point symbol to open the Marker Palette in the Symbol Window.

Step 3 Select a marker symbol

Notice that some of the point symbols in the Marker Palette are solid black and
some are green with a black outline. If you select a solid black marker, the entire
symbol will be one color (whichever color is currently being used by the symbol in
the Legend Editor). If you select a green marker, the symbol will be colored in the
center with a black outline. Click on any green point symbol in the Marker Palette.
From the Size dropdown box, select 10. Notice that the symbol in the Legend Editor
has changed. Click Apply in the Legend Editor.

Step 4 Select a line symbol

The Road-network theme uses three colors of lines to represent road types. You'll
make them more distinctive by using a double line symbol for Dual lane. In the view
Table of Contents, double-click the Road-network theme. The Legend Editor shows
the current symbols. Doubleclick the line symbol next to Dual Lame (divided)
highway in the Legend Editor. The Pen Palette in the Symbol Window opens. Click
on a double line symbol. Click Apply in the Legend Editor

Step 5 Select an area symbol

You might want to use a pattern for the Regions.shp theme display. You can choose a
different pattern for each symbol, or you can apply one pattemn to all the symbols.
Double-click the Reglons.shp theme in the view. The Legend Editor shows the
Region symbols. Double-click the first symbol in the Legend Editor. The Fill
Palette opens. In the Legend Editor window, hold down the Shift key and click on
the other two symbols to highlight them as well. In the Fill Palette, click on a new fill
pattern of your choice. Notice that all the symbols in the Legend Editor show the new
pattern.

Step 6 Modify the area symbol

You can change the color of any symbol using the Color Palette. For polygon
features, you can change the color of the fill or the outline. You'll give the region
features a more subtle appearance by changing their outline to gray. Click on the

16
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Color icon (the one with the paint brush ) at the top of the Symbol Window.
From the Color dropdown list, select Qutline. Click on a gray-colored square.
Notice that the three symbols in the Legend Editor now have a gray outline.

Step 7 Apply your changes
Click the Apply button in the Legend Editor. The Regions.shp theme displays the
new pattern and outline color.

Step & Close the project

From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes. You've experimented
with classifying features and changing the symbols used to display them. This can
have great impact on the way the information is interpreted and how the map is
interpreted.

1.7 Label data

You've seen how classifying features can change the way your map looks and how
you can display map features based on their attributes. You bave also learned how to
change the symbols that represent features. In this exercise, you will add text labels to
features and customize the view's display properties.

Estimated time to complete: 20 minutes

Step 1 Open the project

If necessary, start ArcView. Open the project introav\basics\lesson03\L03_ex04.apr.
When the project opens, you see a view with three themes: a point, a line, and a
polygon theme. The Regions.shp theme is already classified using the Equal Interval
method and a blue-green monochrome color ramp. The Road-network theme is a line
theme in which each road has been classified.

Step 2 Change the view's background color

Notice that the view's background color is white by default. This is usually attractive
on the screen, but assigning a new background color could enhance the readability of
the theme's features. From the View menu, choose Properties. In the View Properties
dialog, click the Select Color button. Click on the light purple box in the Color
Picker, and click OK. Click OK in the View Propertties dialog to apply the new back
ground color to the view.

Step 3 Label data based on an attribute

You are going to label the Regions with their respective names. Click on the check
box next to the Town theme name to turn it off. Click on the check box next to the
Road-network theme name to tumn it ofF as well. The view redraws to reflect your new
choices. Click once on the Regions.shp theme name in the Table of Contents to make
it active. Now it appears raised in the Table of Contents. From the Theme menu,
choose Properties. Click the Text Labels icon. Make sure Region_name is the
choice in the Label Field scrolling bar. Click OK. From the Theme menu, choose

17




A S

o

e & E - €

Auto-label. Click OK to accept the defaults in the Auto-label dialog. Before you
change the current labels' default font, select all the labels by choosing Select All
Graphics from the Edit menu. Now, from the Window menu, choose Show Symbol
Window. The Font Palette displays. Select Arial Black and Size 12. Close the Font
Palette and unselect all labels by clicking anywhere in the view with the Pointer tool

Step 4 Customize the label settings

Rather than labeling every county automatically, now you will manually label some
of them instead. From the Edit menu, choose Select All Graphics. Press the Delete
key on your keyboard. Before adding labels, you'll set the default properties for the
Label tool. The labels will be added using the seitings you specify. From the
Graphics menu, choose Text and Label Defaults. The Default setting for text and
label tools dialog appears. Click on the Label tool shown in the left side of the dialog.
The rest of the dialog updates to reflect the available settings for the Label tool. If it
isn't already blank, remove the checkmark from Use Symbol Window settings for text
by clicking on it. In the Font scrolling list, choose Courier New font. Set the size to

12 and the style to Bold Italic. Click OK. Click the Label tool @ Click inside the
regions you want labeled to add their county names. If you need to move any of the
labels, use the Pointer tool to select a label and move it to a new location.

Step 5 Close the project

Close the project without saving. From the File menu, choose Close All. Again from
the Fill menu, choose Close Project. Click No when prompted to save your changes.
Choose Exit from the File menu to close ArcView.

Self test

(1) You can display a theme based on one of its attributes by selecting an attribute field in the
Legend Editor

c True
C False

(2) You create your own symbo) palette and load it into ArcView
e True

C False

(3) The default symbol for a point feature is a:

e Solid fill square

c Solid fill circle

c Open square

c Open circls
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{4) A chart legend allows you to display more than one feature attribute at a time.
& True
e False

{5) Which classification method groups features into classes having an equal range of
values?

C Graduated Symbo!
e Unigue Value

c Equa! Interval

c Quantile

(6) In a color ramp, the colors of classes graduate based on the lowest to highest field values.
e True
c False

(7) if you want a labe! to point to the feature you are labsling, which of the following label
types could you use in ArcView?

c U.S. Interstate Highway Shiekd label
c Banner label

e Callout labe!

e Spline Text label
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Exercise 2
Working with features

2.1 Get information about features
In this exercise, you will work with a theme on Syria

Estimated time to complete: 15 minutes

Stepl Start ArcView and open the project

Start ArcView. Navigate to the folder \introaviquery\ lesson01 and in the folder,
open LO1_ex0l.apr. You see a view with rain-fed suitability areas of Syria You want
to get information about areas suitable for absolute rain-fed farming.

Step 2 1dentify a feature

With the Identify tool (@) selected, click on any part of the theme. The feature
flashes in the view and a window displays. The left side of the Identify Results
window lists the feature you identified and the right side lists its attributes. These are
the same attributes that are stored in the theme's attribute table.

Step 3 Select some features

Close the Identify Results window. Click the Select Feature tool @ Holding down
the Shift key, click on any part of the theme again. ArcView highlights the selected
features in yellow. If you select the wrong feature, you can unselect it by holding
down the Shift key and clicking on it again.

Step 4 Examine the highlighted records

Click the Open Theme Table button ) on the View button bar. The theme attribute
table opens. At first, you may not see any highlighted records. To see the entire group
of selected records at the same time so you can compare them, you'll use the Promote
button to move them to the top of the table.

Step 5 Promote the selected records to the top

Click the Promote button on the Table button bar. The selected records now
appear at the top of the table.

Step 6 Arrange the view and table windows to sce them both

Click on the table's title bar. Drag the table to the upper left corner of the ArcView
window. Now click on the view’s title bar and drag it to the lower right comer. Make
the view window smaller if necessary.

Step 7 Find areas suitable for rain-fed agriculture

Make the Table window active. Click the Identify tool on the Table toolbar. Scroll
down the table until you see a record labeled Suitable. Click on the record. The
Identify Results window displays and the feature you selected flashes in the view. If
you don't see the feature flash, click on the record again.
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Step 8 Restore the view and close the project

Click the Select None button and close the table. Resize the view window so that
it is approximately the same size as before you opened the table. If you are continuing
on to the next exercise, leave the project open. Otherwise, choose Close All from the
File menu. From the File menu again, choose Close Project. Click No when you're
prompted to save your changes.

2.2 Select features based on their attributes

Assuming you are about to start a project at two towns in Syria and in your
preliminary report you need to give the geographical location of these two towns. You
will use the two names to search for the locations in a database.

Estimated time to complete: 5 minutes

Step 1 Open the project

If LO1_exOl.apr is open, continue to Step 2. Otherwise, start ArcView and open the
project introav\query\lesson01\LO1_ex02.apr. You will see a view with towns
theme.

Step 2 Find the geographical location of a town

With the Towns theme active, click the Find button on the view button bar, Type
Tartus in the text box that displays. Click OK. ArcView searches the attribute table
for the first occurrence of Tartus and selects it. ArcView highlights the record and
the corresponding feature in the view. ArcView also pans the view so the highlighted
feature displays in the center.

Step 3 Examine the town

Click the Promote button ArcView displays the selected record at the top of the
table. By scrolling to the right, you can see the longitude and latitude of this town.
Follow the same step to search for a town called Wuguf.

Step 4 Find area suitable for farming in Aleppo

Make Precipitation theme active. Click the Query Builder button on the view
button bar to display the Query Builder dialog. The Query Builder dialog contains a
list of attribute fields (lef), a set of operators (center), and a list of attribute values
(right). When you click on a field in the Fields list, all the unique values for that field
display in the Values list, as long as the Update Values option is checked (this is the
default). To build a query, you double-click on a field, click (or double-click) on an
operator, then double-click on a value. As you build the query, it displays in the query
text box in the lower left comer of the dialog. You can also type your query directly in
the query text box. Once you enter the query in the text box, you apply it by selecting
New Set, Add To Set, or Select From Set. New Set creates a new set of selected
features that match your query. Add To Set adds features that match your query to the
existing selected set. Select From Set selects features that match your query from the
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previously selected set. With one query, you'll select all contiguous areas known as
farming zone in Hama province of Syria

Step 5 Choose & field

In the Query Builder dialog, scroll down to the bottom of the Fields list, then click on
“[Preciptn]." Double-click on "[Preciptn]” to place it in the query text box. Click on
“[>=]" and type in 200. Click the New Set button. ArcView highlights them in the
view. You may need to move the Query Builder dialog box so you can see the view.
To see all the area that meet the criterion set above, you'll zoom out to them.

Step 6 Zoom out to see all the selected lots
With the view active and Precipitation theme also active, click the Zoom to Selected

button ArcView zooms out so you can see all the selected features. The result
shows that all the areas in the hama province excep! areas in the eastem part are
within the farming zone.

Step 7 Close the project

In this exercise, you used the Find button to locate and select a feature from an
attribute value then used the Query Builder to select a group of features by specifying
an attribute and the desired value for it. In the next exercise, you'll use the Query
Builder from the Theme Properties dialog to select the features you want to display in
the view. From the File menu, choose Close All. From the File menu again, choose
Close Project. Click No when you're prompted to save your changes.

2.3 Filter features

For this exercise, suppose you're a member of an agricultural commission concermed
about the decline of citrus-growing areas due to residential and commercial
development. You want to create a map showing the current citrus-growing areas,
then use it to track future changes in land use.

Estimated time to complete: 15 minutes

Step 1 Open the project

Start ArcView, if necessary. Open the project introaviquery\lesson01\L01_ex03.apr.
You see a view showing streets and land parcels. According to the agricultural
commission, the land parcels were once used exclusively for growing citrus and other
agricultural products, but in recent years they have been converted to residential and
commercial land use. Areas where streets are dense (toward the center of the view)
have undergone the heaviest development. For each feature in the Parcels theme, there
is a land use code. A code of 732 indicates that the land is used for growing citrus.
You will build a query in the Theme Properties dialog to filter the Parcels theme so
that only the land parcels used for growing citrus will be displayed.
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Step 2 Display the Theme Properties dialog

With the Parcels theme active, from the Theme menu, choose Properties. The Theme
Properties dialog displays. By default, the Definition icon is highlighted on the lefi. If
the icon isn't highlighted, click on it to highlight it.

Step 3 Build an expression

Click the Query Builder button in the Theme Properties dialog. The Query
Builder dialog displays. It looks like the Query Builder you access from the View
interface, but instead of the New Set, Add To Set, and Select From Set buttons, it
has OK and Cancel buttons. Make sure the Update Values check box is checked. In
the Fields list, double-click on "[Landuse].” Because there are a lot of unique values
in this field, it may take a while for them to update in the Values list. Click the equals
sign (=) button. Scroll down in the Values list until you find 732 and double-click on
it.

Step 4 Select the parcels that match your query

Click OK in the Query Builder then click OK in the Theme Properties dialog to
display parcels that match your query. ArcView displays the features that match your
query. Now the view shows only the parcels that are used for growing citrus; the other
parcels do not display in the view. Notice that the remaining citrus groves are located
mainly on the outskirts of the city. Next, you'll zoom in to the new Parcels theme.

Step 5 Zoom in to the Parcels theme

Click the Zoom to Active Themes button ArcView zooms in so that the active
theme, Parcels, fills the view. Now you have a theme that shows only the parcels used
for citrus. As land use pattems continue to change, you can copy and then update your
data (o reflect these changes. In this way, you create multiple versions of the data,
each one representing a different time period. By filtering each version of the data,
you can create a series of maps that show changes in citrus-growing areas over time.

Step 6 Close the project
From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.

Self test

(1) The placement of operators in a query expression doesn't affect which features are
selected.

c True

C False

(2) You cannot easily zoom in to selected feature.
c True

e False
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(3) The placement of parentheses in a query expression doesn't affect which features are
selected

C True

c False

(4) You can select features only with a graphic box or circle
c True

c False

(5) One of the fastest ways to get information about a specific feature is to use the:
C |dentify tool

c Promote button

c Clear Selected Features button

c Query Builder

(6) To remove all features from a selected set, you need to:
c Click the Switch Selection button

& Doubte-click the Identify tool

C Click the Select None button

c Click the Promote button

(7) Which tool can you use to select features based on several attributes?
c Find tool

C Select too!

c Select by Graphics button

C Query Builder

2.4 Measuring distances and projecting themes

For this exercise, you will measure some distances, find area of interest and play with
different projections.

Estimated time to complete: 35 minutes

Step 1 Start ArcView and open the project

If necessary, start ArcView. Open the project Introaviquery\lesson02\L02_ex01.apr.
When the project opens, you see a view containing three themes. All of these themes
contain geographic data stored in decimal degrees. (Recall that decimal degrees are
degrees of latitude and longitude expressed as a decimal rather than as degrees,
minutes, and seconds.) Before you make any measurements in the view, you'll tell
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ArcView the type of units in which the data is stored and the type of units you want to
use for measuring.

Step 2 Open the View Properties dialog

From the View menu, choose Properties to open the View Properties dialog. To
specify the units in which the coordinates of the data are stored, you'll set the map
units.

Step 3 Set the map units

Click on the Map Units down amow, then click on decimal degrees in the list. This
indicates that all the data in the current view is stored in decimal degrees. To specify
the units ArcView will use to report measurements, you'll set the distance units. Click
on the Distance Units down arrow and choose meters. Click OK to apply your
settings to the view. Next, you'll use the Measure tool to determine the distance from

the Damascus city to the Aleppo city.

Step 4 Perform the first measurement

Click on the Measure tool £} The mouse pointer changes to a ruler. Now click on
the symbol used to represent Damascus city. Drag the cursor to the symbol
representing Aleppo city. Notice that ArcView draws a line segment from the
building to wherever you position the mouse pointer in the view and reports the length
of this line in the status bar (at the bottom of the ArcView window). With the mouse
pointer directly over the Aleppo city point, double-click to end the line. ArcView
reports the measurement in meter. ArcView reports two values: Segment Length and
Length. Segment Length is the length of the current line segment, while Length is the
total length of all segments that comprise the line. In this case, both measurements are
the same, 350,490.32 meters. (In this exercise, your measurements may vary slightly
from those reported.)

Step 5 Perform the second measurement

Click on the same Damascus point again. This time, drag the mouse pointer to the
Tiyas town. With the mouse pointer directly over the Tiyas point, double-click to end
the line. ArcView reports the measurement in the status bar.

Step 6 Measure area of an object
You'll use the Rectangle tool to draw the shape of a field, 110 x 90 meters.

Step 7 Draw the shape of the field

Click on the Draw tool Select the Rectangle tool from the dropdown list of
tools. Click inside the Tiyas town point, hold down the mouse button, and drag a
rectangle that measures approximately 110 meters by 90 meters. (Check the status
bar to see the Extent--width and height--of the rectangle as you draw it.) When you're
satisfied with the rectangle (your measurements don't have to be exact), release the
mouse button. Next, you'll use the Size and Position function to set the exact
measurements for the rectangle.
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Step 8 Set the exact measurements for the rectangle

From the Graphics menu, choose Size and Position. The Graphic Size and Position
dialog displays. In the dialog, set the width to 110 meters and the height to 150. Click
OK. Now the rectangle has the correct dimensions for a soccer field. To reposition the
rectangle, you'll use the Pointer tool.

Step 9 Reposition the rectangle

Click on the Pointer tool and position the mouse pointer over the rectangle. The
mouse pointer changes to a four-headed arrow. Now, hold down the mouse button and
move the rectangle to any position on the map. In this way, you can determine the
best locations for the field. But suppose you want to change the orientation of the
field? No problem. Just use Size and Position to change the dimensions of the
rectangle.

Step 10 Change the dimensions of the rectangle

From the Graphics menu, choose Size and Position. This time, change the width to
1000 meters and the height to 1000 meters. Click OK. Now you can use the Pointer
tool gain to reposition the rectangle.

Step 11 Set map projection
Click File then Close All to close View1. Open View2.

Step 12 Choose a projection for the view

From the View menu, choose Properties. Click the Projection button. The
Projection Properties dialog opens. Click on the Type down arrow then choose
Mercator from the list. Click OK again click OK in the View Properties dialog to
apply the Mercator map projection to the view.

Step 13 Measure the distance from Damascus to Aleppo

With the Measure tool, again measure the distance from Damascus to Aleppo. The
new measurement is larger than the previous measurement (Your measurements may
vary). The ellipse is now a circle (its true shape). The Mercator map projection
preserves the property of direction and the shape of features, but sacrifices accurate
distance and area, You'll change the projection again.

Step 14 Change the projection again

From the View menu, choose Properties. Click the Projection button. In the
Projection Properties dialog, click on Peters in the Type dropdown list. Click OK
againn click OK in the View Properties dialog to apply the Peters map projection.

Step 15 Measure the distance from Damascus to Aleppo

With the Measure tool, measure the distance between the two cities. The new
measurement is smaller than the last measurement. The circle is now egg-shaped. The
Peters projection preserves accurate area but sacrifices the properties of shape,
distance, and direction. The two previous projections, Peters and Mercator, are most
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suitable for regions near the equator. Next, you'll use a projection that's suitable for
the Syria.

Step 16 Change the projection again

From the View menu, choose Properties. Click the Projection button to display the
Projection Properties dialog. Click on the Category down arrow then select UTM
1983. Click on the Type down arrow to display a list of zones. Select Zone 37 (Note:
Syria falls to zone 37 and 38 but most part is in the zone 37). Click OK again click
OK in the View Properties dialog to apply the new projection. Now you'll measure
the distance between Damascus and Aleppo

Step 17 Measure the distance from Damascus to Aleppo

Click on the Measure tool and measure once more the distance between Damascus
and Aleppo. This time, the distance (~350) is almost the same to the one measured in
step 4 and the ellipse is now a circle. After working through this ArcView
demonstration, you can see how shape and distance change from one projection to
another. Much of the data you buy is stored in geographic coordinates, usually
decimal degrees. As you've seen, you can work with this data without projecting it, or
you can apply any of the standard or custom projections ArcView supports. Data
stored in decimal degree is most flexible

Step 18 Close the project

From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes. If you want to go on
1o the next lesson, leave ArcView running. Otherwise, choose Exit from the File menu
to exit ArcView.

Self test

(1) Latitude/Longitude is a spherical coordinate system.

C True

C False

(2) The Measure tool is used to find the distance between features.

c True

c False

(3) In ArcView, you can measure the distance of only one line segment.
c True

e False
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(4) A view's map units and distance units must be set to the same unit of measure.
e True
c False

(5) What can you use to change the proportions of a graphic in a view?
c Select Feature tool

C Resize too
e Size and Position option under the Graphics menu
c Select Graphic tool

(6) If you look in the View Properties dialog and see "unknown" for both the map units and
distance units, it means that your view contains projected data.

C True
Cc

False

(7) Where can you change a view's distance units?
e Legend Editor

c View Properties dialog

# Theme Properties dialog

c Projection Properties dialog

Managing scale

2.5 Change the scale of a view

For this exercise, suppose you work with a Non-governmental Organization (NGO)
and a company who is interested in opening a new international sales office in Italy
approaches your organization for help. As the European market analyst for the
organization, you have been asked to study potential sites - among them Milano,
Genova, Roma, Napoli, and Palermo. After much research, you have concluded that
Milano is the best site for the new office. You want to present your arguments to the
management. Some of them are not familiar with your market region, so you want to
use maps at the beginning of your presentation to orient them to the European sales
region and the potential sites you considered. Then you want to zoom in on Milano as
you describe why it is the best site for the new international sales office.

Estimated time to complete: 15 minutes
Step 1 Start ArcView and open the project
Start ArcView, and open the project introaviquery\lesson03\L03 ex0l.apr, if

necessary. When the project opens, you see a view of the world from space showing
the European sales region, the country of Italy, and the proposed sites (not
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distinguishable at this scale). This is the scene you want to show at the beginning of
your presentation. Notice that the scale box on the right-hand side of the view toolbar
shows a value of 1:188,403,856. This value is the scale fraction or scale ratio. It tells
the relationship between the size of the area in the view and the size of the same area
in the real world. In this case, it means that 1 inch on the screen represents
188,403,856 inches on the Earth. ArcView calculates a view's scale using the current
map units. To determine how the map units for this view are set, you'll display the
View Properties dialog. Note: During this exercise, do not maximize or resize the
view window, as this alters the view's scale. Your scale values may vary slightly from
those shown, depending on your screen’s resolution, font size, and other factors.

Step 2 Display the View Properties dialog

From the View menu, choose Properties. The View Properties dialog displays. You
see that the map units are set to meters and the Projection field shows that one of the
Orthographic projection types has been applied to the view. The Comments section
tells you that the map projection for this view is The World from Space.

Step 3 Close the View Properties dialog

Click the Cancel button to close the View Properties dialog. For your next scene in
the presentation, you want to show a more detailed view of the European sales region,
so you'll zoom in to that theme.

Step 4 Zoom in to the European sales region

With the Sales Reglon theme active, click the Zoom to Active Themes button .
ArcView zooms in so that features in the Sales Region theme fill the view window.
Note that the value in the scale box changes to 1:30,929,728. (The actual scale box
value displayed in your window may vary slightly from this exercise.) This is the
scale ArcView calculated based on the size of the view window and the size of the
real-world area shown. Notice that the denominator of the scale fraction, 30,929,728,
becomes smaller as you zoom in. For the next scene, you want to zoom in to the Italy
theme to look more closely at the proposed office sites.

Step 5 Zoom in to the Italy theme

Make the Italy theme active and click the Zoom to Active Themes button &3,
ArcView zooms so that features in the Italy theme fill the view window. The value in
the scale box changes to 17,274,333, (The actual scale box value displayed in your
window may vary slightly from this exercise). When you present your arguments for
citing the new sales office in Milano, you want to show Milano at the center of the
view. So, next, you'll select it and zoom in to it.

Step 6 Select Milano in the Proposed Sites theme

Make the Proposed Sites theme active. Click on the Select Feature tool @ Now
click on the feature (point) that represents Milano. ArcView selects and highlights it.
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Step 7 Zoom to Milano

Click the Zoom to Selected button ArcView pans the view so Milano appears in
the center of it. In this case, ArcView doesn't zoom in any further, so the scale
remains the same. At any time during the presentation you're planning, you may want
to return to a view of the entire sales region. You could make the Sales Region theme
active then click the Zoom to Active Themes button. Or, you could click the Zoom

~
to Previous button to go back to the previous zoom. Instead, you'll enter a value
in the scale box. In Step 4, you zoomed in to show all the features in the Sales Region
theme. The value in the scale box was 30,929,728. You will use this value (rounded
off) to set the scale directly.

Step 8 Set the scale

Click in the scale box, drag the cursor to highlight the current value, then type
32,000,000 and press Enter. The view redraws at this scale. Notice that the view is
still centered on Milano. You will reposition the display using the Pan tool.

Step 9 Reposition the display

Click on the Pan tool Move the mouse pointer (now a hand) anywhere over the
display. Hold down the mouse button and drag the display (slightly) up and to the left,
then release the button. ArcView redraws the view, filling in any blank areas. You're
ready for your presentation. You've practiced several ways of zooming in and out and
you have set the view scale directly. Your presentation using ArcView's world data
and zooming tools will help your audience visualize the sales region and the site
you're proposing for the new sales office.

Step 10 Close the project
From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.

2.6 Set theme scale thresholds

Suppose you're a part of research team that is collecting data on consumption pattems
for a city area, The project is designed in such a way that data collected on households
on highway roads are separated from the ones from the streets in the city. You need to
display the location of each household. GPS (Global Positioning System) was used to
collect the locations. Your task is to come up with a way to store all the themes you
need for the project in the same view and be able to work with them at different
scales. For example, when you examine locations along the city streets, you need to
zoom in more than when you examine locations along highways. At each scale, you
want to display certain themes but not others. To support the different scales you'll be
working at, you'll use ArcView's display theme property to set scale thresholds for
drawing themes.
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Estimated time to complete: 15 minutes

Step 1 Open the project

Start ArcView, if necessary, and open the project
introav\query\lesson03\L03_ex02.apr. When the project opens, you see a view
containing five themes. The Text theme contains the names of towns and major
highways, the City locations theme contains the locations of households along the
streets in the city, the Highway locations theme contains the locations of households
along the highways, the Road-network theme shows road network of the city, and the
Streets theme contains all the city streets for the city area. Right away, you can see
that this view is cluttered. At this scale, you can't interpret the information each theme
presents without manually turning each theme off and on. To see the Highway
locations better, you'll turn some themes off. Note: During this exercise, do not
maximize or resize the view window, as this alters the view's scale. Your scale values
may vary slightly from those reported, depending on your screen's resolution, font
size, and other factors.

Step 2 Turn off the City locationsand Streets themes

Click on the check box next to the City locations and Streets themes to turn them
off. Now you can easily see where the Highway locations are, which highways they're
on, and which cities they're near. To see the City locations instead, you'll tum on
different themes.

Step 3 Turn on some different themes

Click on the check boxes next o the Text, Highway Accidents, and Road-network
themes to turn them off. Do the same for the City locations and Streets themes to tum
them on. Now you can see the city accidents, but at this scale, you don't clearly see
which streets they're on. To zoom in enough to see which street each accident is on,
you'd have to click the Zoom In button about six times. Because of the density of the
streets, the view takes a long time to draw, so you won't use this method of zooming
in. Instead, you'll set a scale directly in the scale box.

Step 4 Set a scale in the scale box

Click in the scale box, highlight the current value, then change the value to 150,000
and press Enter. At this scale, you can see the City locations and the streets they're
on. You'll use ArcView's display theme property to set a scale threshold that prevents
the streets from drawing until you've zoomed in enough to see them clearly (about
1:150,000 scale). Next, you'll return to the original view scale.

Step 5 Return to the original view scale
Click the check boxes next to the themes that are tumed off to turn them on. Click the

Zoom to Full Extent button & ArcView zooms out so you can see all the features
in all the themes. Next, you'll set a scale threshold for the Streets theme.
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Step 6 Set a scale threshold for the Streets theme

With the Streets theme active, choose Properties from the Theme menu to display
the Theme Properties dialog. Scroll down to the Display icon along the left margin
and click on it. Type 150000 in the Maximum Scale input field. Don't enter a value in
the Minimum Scale input field. Click OK. Because the value in the view scale box is
larger than 150,000, the Streets theme no longer draws, even though it's turned on in
the Table of Contents.

Step 7 Change the scale to 149,999

Click in the scale box, highlight the current value, change the value to 149,999 and
press Enter. The Streets theme draws when the scale box contains a value smaller than
150,000.

Step 8 Zoom in and set a scale threshold for the Text theme

Click the Zoom to Full Extent button. Make the Text theme active and choose
Properties from the Theme menu. Click on the Display icon along the left margin.
Type 150000 in the Minimum Scale input field. Click OK. Now the Text theme won't
draw if the value in the scale box is smaller than 150,000.

Step 9 Change the scale to 149,999

In the view, click in the scale box, highlight the current value, and type 149,999,
Press Enter. The Streets theme draws and the Text theme doesn't. The City locations
are no longer covered up by text and you can see the streets they're on. You can set a
range of scales for displaying a theme. For example, if you set a minimum scale
threshold of 50,000 and a maximum scale threshold of 100,000, the theme will
display only when the value in the scale box is between these two values. You've
completed your task of creating a way to display themes associated with this project.
By setting theme scale thresholds, you can display the information you need at the
right scale, allowing you to work effectively with many themes in the same view.

Step 10 Close the project

From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.

Exit ArcView.

Self test

(1) You can enter a specific scals in the scale box to zoom in or out on a view.

c True

c False

{2) For ArcView to report the view scale, you must set the map units in the View Properties
dialog.

C True

& False

32




(3) Zooming in or zooming out does not change the scals of the view.
C True
# False

(4) To display properly, all themas in a view must have the same scale threshold set.

True

(® False

{5) Where do you set the scale threshold for a theme?
c In the Theme Properties Display section

c In the Theme Properties Definition section

C In the Query Buitder

C

In the scale box

(6) A 1:20,000 scale is larger than a 1:30,000 scale.
e True
9 False

(7) In ArcView, the scale reported In the view's scale box is a:
C Decimal value

c Representative fraction

e Verbal scale

e Linear scale
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Exercise 3
Presenting information

3.1 Prepare data for charting

In some cases, presenting your reports in chart forms helps to convey your ideas
quickly to the intended audience. ArcView GIS has a light’'s weight charting
capabilities. You'll learn how to do this in these exercises using data from the Far
East.

Estimated time to complete: 15 minutes

Step 1 Start ArcView and open the project

Start ArcView and open the project introav\present\lesson01\L01_ex01.apr. When
the project opens, you see a view with two themes: Siberian Rivers and Far East (a
theme showing the region of Siberia and adjacent countries). The Siberian Rivers
theme is active.

Step 2 Open the Attributes of Siberian Rivers table

Open the theme table for the Siberian Rivers theme. The table contains the names of
the major Siberian rivers, their lengths in miles, and other attributes. You want to
create a chart comparing the attributes in this table. In the process, you may select
certain records in the table to chart. But selecting these records also highlights the
corresponding features in the view. If you don't want to highlight these features, you
can make a separate copy of the theme table and use it to create your chart. The copy
isn't linked to the view, so you can select its records without affecting the view. To
make a copy of the theme table, you'll export it to a DBASE file.

Step 3 Export the theme attribute table to a dBASE file

With the Attributes of Siberian Rivers table active, from the File menu, choose
Export. The Export Table dialog displays. dBASE is the selected (default) format.
Click OK. Another Export Table dialog displays, where you specify the name and
location of the file to which you want to export the table. Specify your c:\temp folder
as the folder where you want to save the export table. Type rivers.dbf as the
filename. Click OK. A new file is created containing all the records from the attribute
table. Next, you'll add the new file to your project as a table using the Project window.

E . Click the Add

Step 4 Add the new file to your project as a table

Make the Project window active then click the Tables icon
button to display the Add Table dialog.



-

Step 5 Open the new table

If necessary, navigate to your c:Mtemp folder. Select rivers.dbf and click OK. The
rivers.dbf table displays, and its name is added to the list of tables in the project. Next,
you'll hide some of the fields in rivers.dbf and rename it to make the name more
descriptive.

Step 6 Rename the table and hide fields

With rivers.dbf active, from the Table menu, choose Properties. The Table
Properties dialog displays. The bottom of the dialog contains a scrolling list of the
table’s fields with checkmarks indicating whether or not each field is visible. In the
Title field at the top of the dialog, type Major Siberian Rivers. In the scrolling list at
the bottom of the dialog, click on the checkmarks next to the River_ and River_id
fields to make them invisible. Click OK. The River_ and River_id fields are now
hidden.

Step 7 Close the table
Close the Attributes of Siberian Rivers table. Your data is now ready for charting.

3.2 Create and edit a chart

Now you’ll create a chart comparing the attributes of Siberian rivers. You'll use the
Major Siberian Rivers table you created in the previous exercise to generate the chart.
When you create a chart, ArcView displays it with a default format, axes, title, and
legend, and assigns a default set of colors to the data markers (e.g., columns, bars, pie
slices). You can change the way a chart looks by modifying any of its elements.

Estimated time to complete: 20 minutes

Step 1 Open the project

If LO1_ex01.apr is open, go to Step 2. Otherwise, start ArcView if necessary and open
the project introav\present\lesson01\L01_ex02.apr. When the project opens, you see
a view showing the Siberian Rivers and Far East themes. From the Window menu,
choose Major Siberian Rivers. The Major Siberian Rivers table opens.

Step 2 Open the Chart Properties dialog
Click the Create Chart button to open the Chart Properties dialog. In the Name

field, change the name to River Lengths. The Fields scrolling list displays the names
of all chartable (numeric) fields in the active table, except hidden fields.

Step 3 Chart the Length field

In the Fields list, click on Length then click Add. This places the Length field in the
list of groups to be charted. Below the Fields list, the Label series using dropdown list
displays the fields you can use to label each item in your chart.
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Step 4 Plot the river lengths

In the Label series using dropdown list, click the down arrow and choose Name.
Click Add then Click OK. ArcView plots the river lengths in the default chart format.
The River Lengths chart compares the values of a single variable (length). For this
type of comparison, a column or bar chart is best. Next, you'll refine the chart. (You
may want to enlarge the chart window so the elements are easier to see). Notice the
labels on the y-axis. The lowest is 1000, the highest 3000, and the increment is 200.
You'll madify these settings using Chart Axis Properties so the data markers for
shorter rivers are more prominent. A colored bar, or data marker, indicates the length
of each river. The name of each river appears in the chart's legend.

Step 5 Display the Chart Axis Properties dialog box

With the chart active, click on the Chart Element Properties tool &), Click
anywhere on the y-axis of the chart. The Chart Axis Properties dialog displays.

Step 6 Refine the chart

In the Scale max text box, highlight the default value and type 3500. This sets the
upper limit on the y-axis. (The lower limit is already set to 0). In the Major unit text
box, replace the default value with 500 to adjust the increment. In the Axis label text
box at the bottom of the dialog, highlight "Y Axis" and replace it with the word
Miles. Click on the Axis label check box (near the top left of the dialog box) to tum it
on. Click OK. The chart redraws with the changes you made. The chart looks better,
but it's still rather difficult to follow the y-axis labels across to the columns.

Step 7 Add gridlines to make the chart easicr to read

Click again on the chart's y-axis to reopen the Chart Axis Properties dialog. Click the
Major grid check box then click OK. The chart redraws with gridlines that make it
easier to read. Notice that the attribute you're charting, "Length,” is currently
displayed along the bottom of the chart. This is the Group label. You'll also add an x-
axis label to the bottom of the chart.

Step 8 Add an x-axis label to the bottom of the chart

Click anywhere on the chart's x-axis to open its Chart Axis Properties dialog. In the
Axis label text box at the bottom of the dialog, highlight "X Axis" and replace it with
the words Note: The Mississippi River is 2470 miles long. Click the Axis label
check box to tum it on. Click OK. Now you'll give your chart a title.

Step 9 Give your chart a title

Click on the word "Title" at the top of your chart to open the Chart Title Properties
dialog. The title has five fixed positions you can click on: top, bottom, left, right, or
middle. (If you choose the middle position, you can place the title anywhere you
wish.) You'll leave the title at the top (the default position). In the text box, type
Major Siberian Rivers. Click OK. The chart redraws with the new title. Your chart
looks good, but you want to change the gray color representing the Yenisey to a more
vivid color. For this, you'll use the Chart Color tool.
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Step 10 Change a data marker color

Click the Chart Color tool @ in the Chart toolbar. When the Symbol Window
displays, open the Color Palette. In the Color Palette, click on the russet square (the
square diagonal to black). A black border appears around the square to indicate that
it's selected. In the chant, click on the gray data marker for the Yenisey River. The
color of the data marker changes to russet, and the legend symbol changes to match.
Close the Symbol Window.

3.3 Query a chart

Because ArcView charts are dynamically linked to the tables from which they're
created, you can get information from the table by simply clicking on the chart. In
addition, you can edit the source table for the chart and the chart immediately reflects
the change. You'll further refine the charts you made in the previous exercise here,

Estimated time to complete: 10 minutes

Step 1 Open the project

If either LO1_exOl.apr or LOl_ex02.apr is open, go to Step 2. Otherwise, start
ArcView if necessary and open the project introavipresent\lesson01\L01_ex03.apr.
When the project opens, you see a view containing the Siberian Rivers and Far East
themes. From the Window menu, choose River Lengths. The River Lengths chart
opens. Each data marker in this chart corresponds to a record in the Major Siberian
Rivers table. Using the Identify tool, you can click on any data marker to display the
corresponding record in the table.

Step 2 Identify a river

Click the Identify tool on the Chart toolbar if it's not already selected. Click on
the green data marker for the Amur River. The corresponding record displays in the
Identify Results window. Clicking on additional data markers adds them to the
Identify Results window.

Step 3 Make the view active

Close the Identify Results window. Make the view active by clicking on its title bar.
With the view active, you can see that the Kolyma River in northeastern Siberia is
extremely remote and inaccessible, making it too expensive and difficult to launch an
expedition there. You want to remove the Kolyma from your chart.

Step 4 Remove a record from the chart

From the Window menu, choose Major Siberian Rivers. Again from the Window
menu, choose River Lengths. The table and chart are now visible in front of the view.
Resize them to fit in the bottom half of your ArcView window. Click on the title bar

of the chart to make it active. Click the Erase tool @ In the chart click on the
yellow data marker for the Kolyma River. Notice that the Kolyma data marker
disappears from the chart. In the table, all records are selected except the Kolyma
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record. Only the selected records are charted. Notice also that the colors of the data
markers have shifted one position to the right, eliminating the russet color.

Step 5 Close the project
From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.

Self test

(1) Bar charts are usefu! for comparing discrete data values.
¥ True
e False

(2) After you create a chart, it will not reflect changes in the table data.
C True
C False

(3) Line charts are useful for showing trends.
c True

C False

(4) You cannot modify a chart's title.

e True

C False

(5) In which dialog can you add or delete a chart's Groups?
c Chart Properties

& Element Editor

C Group Properties

c Group Editor

(6) Which tool do you use to query a chart data marker?
c Edit too!

e Chart Element Properties tool

C Chart Elements tool
c Identify too!
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{7) Which tool can you use to delete a data marker from a chart?
¥ Element too)

c Select too}

c Chart Data too!

c Erase tool

(8) On an ArcView chart, a "group” is analogous to a:
c Theme

C Data marker

& Record

c Field

Creating map layouts

3.4 Create a basic map layout

In this exercise and the next; you'll create a layout that includes a view of land use and
land cover of Syria, a table of the LULC theme, and a chart comparing the area of
each land use and cover.

Estimated time to complete: 20 minutes

Step 1 Open the project

Start ArcView and open the project introavipresent\lesson02\L02_ex01.apr. When
the project opens, you see a view, a table, and a chart. You'll create a layout
containing these documents.

Step 2 Create a layout

Make the Project window active by clicking on its title bar or by choosing
102_ex01.apr from the Window menu. Click the Layouts icon then click New. A
blank layout page appears. If the orientation of your layout page is landscape
(horizontal), choose Page Setup from the Layout menu and change the orientation to
portrait (vertical). The layout page is too small to work with effectively, so you'll
enlarge it.

Step 3 Enlarge the layout window
Click on the icon in the Layout window's title bar and select Maximize to make the

layout window full-size. Click the Zoom to Page button to fit the layout page to
the enlarged layout window. Now that the layout page is larger, you see grid dots.
These dots are used to snap elements to precise locations in the layout. Grid dots
appear only on the screen, not on the printed layout. If you don't want to show the grid
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as part of an on-screen presentation, you can hide it by clicking Hide Grid in the
Layout menu. Before you add elements to your layout, you'll set up the layout page.

Step 4 Edit the page setup

From the Layout menu, choose Properties. The Layout Properties dialog displays.
Change the name in the Name field to Land Use and land cover. In the Horizontal
text box, change the grid spacing to 0.5. In the Vertical text box, change the grid
spacing to 0.5. This sets the grid points 0.5 inches apant. Click OK.

Step 5 Change the page size

From the Layout menu, choose Page Setup. The Page Setup dialog displays. Click
the Page Size dropdown amrow and choose Letter 8.5 x 11.0 in. Click OK. The layout
will be sized to fit an 8 1/2 x 1l-inch piece of paper. You can even choose the

N
orientation of the paper — Landscape or portrait. Click on Landscape symbol L=
Now that you've finished the basic page setup for the layout, you can begin to add
views, tables, charts, and other elements using the Frame tool. The Frame tool is
actually a set of dropdown tools on the Layout toolbar. There is an icon for each of
the following types of frames: view, legend, scale bar, north arrow, chart, table,
and picture. You'll use the View Frame tool first.

Step 6 Create a view frame

Click the bottom right comer of the Frame tool and hold down the mouse button
to display the dropdown tools. The View Frame tool is the first icon in the list. Click
on it to select it. Inside the layout, place the mouse pointer (now crosshairs) on the
upper left grid point, then click and drag to draw a view frame in the upper portion of
the layout. When you release the button, the View Frame Properties dialog displays.

Step 7 Add a view to the frame

Click on the Land use /land cover of Syria view in the View scrolling list. Live Link
is already checked, specifying that the view frame will be linked to the view. This
means that changes to the view will be automatically reflected in the view frame.
Scale is set to Automatic, so the view will be resized to fit inside the view frame.
(When you choose Preserve View Scale or User Specified Scale, the scale of the view
is fixed in the view frame, and you may not see the entire view).

Step 8 Set the view to always display

Click on the Display dropdown list and choose Always. When you choose Always,
the view in the view frame will continuously display, even when the layout document
is not active. Presentation, the default choice in the Quality dropdown list, indicates
that the view rather than a shaded box will display in the frame.

Step 9 Draw the view in the frame

Click OK. The Land use /land cover of Syria view draws in the view frame. The four
black handles indicate that this frame is currently selected.
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Step 10 Create a legend frame
Click on the Frame tools dropdown list. This time, choose the Legend Frame tool

Inside the layout below the view frame, click and drag to draw a box for the
legend frame about one-third the size of the view frame. When you release the mouse
button, the Legend Frame Properties dialog displays. The View Frame scrolling list
shows the view frames that have already been placed in the layout.

Step 11 Add a view legend to a frame
Click on ViewFramel: Land use /land cover of Syria then click OK. The legend
associated with this view frame draws on the layout. If you don't like the size of the

legend, you can change it with the Pointer loolm. You'll do that in the next step.

Step 12 Resize a frame

Click on the Pointer tool @. Move the mouse pointer over one of the four handles
around the legend frame until it changes to a double-headed arrow. Hold the mouse
button down and drag the handle to change the size. The legend frame snaps to the
nearest grid point and the legend redraws. To move a layout element without resizing
it, select it with the Pointer tool, move the mouse pointer over the element (not on a
handle) until it changes to a four-headed arrow, and drag the element to a new
location as you hold the mouse button down. Next, you'll add a scale bar to the layout.
The scale bar has its own frame in the layout and is associated with a view frame.

Step 13 Create a scale bar frame

Choose the Scale Bar Frame tool from the Frame dropdown tools. Drag a scale
bar frame box in the layout just as you did the view and legend frames. The Scale Bar
Properties dialog displays. In the Scale Bar Properties dialog, select ViewFramel:
Land use /land cover of Syria 1991. Click the dropdown arrow for the Style field and
choose a scale bar style, then click OK. The scale bar draws inside the scale bar
frame in the layout. If you like, resize or reposition the frame using the Pointer tool.

Step 14 Select and draw a north arrow

Finally, you'll add a north arrow to the layout Select the North Arrow Frame tool
from the Frame dropdown tools. Drag a north arrow frame box in the layout. The
North Arrow Manager dialog displays. Select a north arrow and click OK. The north
arrow draws inside its frame. Use the Pointer tool if you want to resize or reposition
the north arrow. Your layout now contains all the main map elements. In the next
exercise, you'll add a table and chart to your layout.

Self test

(1) The grid of dots that appears when you're creating a layout also appears on the printout
unless you tum it off.

c True
e Failse

41




(A4

IncAe s

8jqey) 3

awey) 3

SWEY MBIA 3

01 pavul Jeq 9jeds B S1 18um (8)

dnyes efed 3

jo0} ¥p3 Jnoken 3

sajpadold meiA s

seedold Jnoien] 3

2noke) e Joj 8zjs abed sy 19s noA op Bojelp youm uj {2)

"MBJA 8Y) 0} 8)ew nok abueyd Aue Joajjal sAemie ssiuel MSIA (S)

esies o
en) o
“dew e u) [|g)ap yonw ooy moys o} ejqissod s)it ()

osjed

d
anuy s

“painsesw 8q ued pue Ajjeauawnu pesseldxs s] Jey) ejep St uogeulrojul saneluend (g)

esjeJ 3

aru)
8 |

JusWINoop JnoAe|

B gjeasd jsnw nok ‘mainaly Ul puabs) pue ‘moue Yuou ‘5eq ajeds e yw dews e sjeasd 0] (2)

.

_5. -—-j .,_3 \h—‘-g [ .ﬁj

3

[

3 .3 __3

3

L‘__,vg

3 3



3.5 Adding finishing touches to the layout
In the next exercise you'll add other elements to complete the layout.

Estimated time to complete: 10 minutes

Step 1 Open the project

If L02_ex0l.apr is open, go to Step 2. Otherwise, start ArcView il necessary and open
the project introav\present\lesson02\L02_ex02.apr. If the layout is not the active
document, from the Window menu, choose Land use /land cover of Syria. You see
a layout composed of a map showing the land use and land cover of Syria, along with
a legend, north arrow, and scale bar.

Step 2 Create a chart frame

Select the Chart Frame tool EE] from the Frame dropdown tools. Draw a chart frame
in your layout. The Chart Frame Properties dialog displays.

Step 3 Add the chart
In the Chart Frame Properties dialog, select Land use & land cover of Syria and
click OK. The chart draws inside the chart frame.

Step 4 Create a table frame

Next, select the Table Frame tool 2 from the Frame dropdown tools. Draw a table
frame in your layout. The Table Frame Properties dialog displays.

Step 5 Display the table in the layout

Choose the Land use /land cover of Syria table and click OK. The table draws in
your layout. If you like, reposition it with the Pointer tool. Your layout is complete for
now. It contains all the elements needed to clearly present the information you've
assembled on land use and land cover of Syria. Later, you could add a title and size
and position all the elements into the most pleasing composition. A layout is created
by combining ArcView documents, such as views, charts, and tables, with map
elements, such as a legend, scale bar and north arrow. Each element is added by
creating a frame on the layout page using a Frame tool. The last item is, however,

grid.
Step 6 Add Grid
Grid coordinate is essential for map production. Fortunately, ArcView GIS comes

with an extension for this purpose. Now, Click on the File menu and Extensions sub-
menu. Scroll to Graticules and Measured Grids of the Dialog box that appears.

Check the box and Click OK. ArcView adds a tool . Click on this tool.
Step 7 Using the tool
From the first window that appears uncheck Create a measured grid. Click Next.

Check Labels only from the Choose option for your graticule. From Choose
latitude and longitude option, enter 1 for degrees for each box and click Next follow
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by Finish. Click on the Pointer tool and Click anywhere on the layout. Note: This
extension has many features you can play around it at your post.

Step 8 Export the layout

In most cases you will need to export your layout to other sofiware formats for other
purposes. Click File and Export. A file save dialog box appears. Enter Land-use for
the File Name. For Directory, scroll to your temp folder on your local disk. Select
appropriate drive letter for the Drives. Click on the List Files of Type option. A list of
formats supported by the ArcView GIS appears. Select JPEG. Click on the Options.
From the dialog box Type 300 for the Resolution (DPI) and Select 100 for Quality.
Click OK. Click OK again. You can use any of the Desktop publishing sofiware such
as Adobe PhotoShop to process the image further or insert the image directly into a
Word processing document.

Step 9 Close the project
From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes

Self test

{1) Templates are used to create more than one layout with the same format.
e True
c False

(2) A template stores the locations of frames in a layout.
c True
c False

(3) You cannot simplify a legend frame.

(4) You can use the Text tool to change the color of text.
C True
e False

(5) A legend is the only layout element that can be simplified.
c True
c False
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Exercise 4
Working with records

Selecting table records, just like selecting theme features, is a fundamental concept in
ArcView GIS. You must know the process for selecting and querying table records to
fully understand and get the most information from your data. When you select
records in a table, you can work with specific groups or subsets of data. Often, table
records represent features in a theme, but this is not always the case. A table can be
completely unrelated to a theme, yet you can still manipulate it in ArcView and use its
data to derive statistics and create reports and charts.

4.1 Select records

For this exercise, suppose you are a rangeland manager. It is your job to identify areas
in your mandate areas that are threatened by drought. In your GIS database, two
themes represent rainfall data. One theme contains line features (contour lines) that
define the boundaries of areas with given amounts of rainfall. The other theme
contains polygons that define the areas between the lines. Each polygon is coded with
the highest rainfall value of its two bounding lines. So, if the 200 mm and 250mm
lines bound a polygon, it receives the maximum value of 250 millimeters of annual
rainfall. You'll use the Query Builder to find and select polygons that receive less than
300 millimeters of rain per year. These areas are considered drought-threatened. From
the selected set of records, you could derive statistical information and present the
information in a chart.

Estimated time to complete: 10 minutes

Step 1 Start ArcView and open the project

If necessary, start ArcView. Next, open the project
introavitables\lesson01\L01_ex01.apr.-When the project opens, you see a view with
two themes: Contours.shp and Rainfallshp. You'll also see the Attributes of
Rainfall.shp table.

Step 2 Open the Query Builder

Make the Attributes of Rainfall.shp table active then click Query Builder button .
The Query Builder dialog displays with the name of the active table in its title bar.
The Query Builder dialog is where you build the query expression that ArcView uses
to select records from a table. In this case, you want 1o find all areas that receive less
than 300 mm of rain per year.

Step 3 Create a query expression

Make sure the Update Values check box is checked. In the dialog, scroll down in the
Fields list until you find [Rainfall] and double-click on it. Click the less than (<)
button then double-click on 300 in the Values list.




Step 4 Examine the selected records

Click New Set button to select all the records that match your query. Close the Query
Builder dialog. The records selected by the query expression are highlighted in the
attribute table and the associated features are highlighted in the view. To see the

- L
selected records all together, click the Promote button to move them to the top
of the table. On the top, left side of the toolbar, you can see that 7 of 67 records are
selected. You will work with these records in the next exercise.

4.2 Work with selected records

In this exercise, you'll continue where you left off in the previous exercise. You'll use
ArcView's statistics function to calculate the total area of the district threatened by
drought and use the summarize function to determine how this area is distributed
between the various rainfall contours. Then you'll create a chart to show your results.

Estimated time to complete: 20 minutes

Step I Open the project
If necessary, make the Attributes of Rainfall.shp table active. Records with an annual
rainfall of less than 300 mm (millimeters) have already been selected.

Step 2 Make a ficld active

Click the Promote button to move the selected records to the top of the table. In
the Attributes of Rainfall.shp table, scroll to the last field on the right, Areakm (area
in kilometer), and click on the title of the Areakm field to make it the active field (the
field name cell will appear shaded).

Step 3 Generate statistics

From the Field menu, choose Statistics. A message box displays statistics about the
Areakm field's values for the selected records. You'll see that 41999.1664 square
kilometers of the district receive less than 300 mm of rainfall annually. Click OK to
dismiss the message box. Next, you'll use Summarize to determine how this total
area is distributed between the various rainfall contours.

Step 4 Make the summary field active
In the Attributes of Rainfall.shp table, click on the Rainfall field name to make it
active. You'll summarize the selected records based on the values in this field.

Note:

You can summarize selected records in a table based on the values in the
activefield (in this case, Rainfall). For each unique value in the active field,
ArcView creates a record in the new summary table, Each record contains a
Count field that shows the number of records with that value. Additional
fields contain any summary statistics (e.g., average, minimum, maximum)
vou reauested for fields other than the active field
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Step 5 Summarize the selected records

From the Field menu, choose Summarize. The Summary Table Definition dialog
displays. In the Field dropdown list, click on Areakm. In the Summarize by
dropdown list, click on Sum. Click Add. Your selection moves to the box on the
right. Next, click the Save As button and navigate to your \temp directory. Save the
table as rainsum.dbf. Click OK to retum to the Summary Table Definition dialog.
Click OK again to create the summary table.

Step 6 Examine the results

Examine the rainsum.dbf table. You can see that the new table has three records, one
for each unique Rainfall value. The Count field tells you how many selected records
each value has For example, five areas receive 200 mm of rain a year. The
Sum_Areakm field tells you the total size (in square kilometers) of areas vulnerable
to drought, according to the amount of rainfall they receive. You want to share these
findings with the policy makers, so you'll create a chart showing the information in
the summary table.

Step 7 Display the Chart Properties dialog

A chart is a good way to graphically display tabular information and give it immediate
impact. Your audience doesn't have to think about the difference between 6,228;
14,642; and 21,129 square kilometers. They see and understand. Click on the

rainsum.dbf table to make it active then click the Create Chart button . The
Chart Properties dialog displays.

Step 8 Create a chart

In the Chart Properties dialog, select Sum_Areakm in the Fields scrolling list. Click
Add. Sum_Areakm appears in the Groups list on the right. This is the field ArcView
will plot on the chart. Now, select Rainfall in the Label series using dropdown list.
ArcView will use this field to label each set of related values in the chart.

Step 9 Add the chart to your project

Click OK to apply your selections and close the Chart Properties dialog. ArcView
creates the chart and adds it to your project. Notice that a red symbol appears at the
top of the chart's legend, but you don't see a red column in the chart. That's because
ArcView uses the smallest value of Sum Areakm (6,228.31, rounded down to 6,000)
as the minimum value on the y-axis. Now you know which areas in your district are
vulnerable to drought and you know the size of these areas. Armed with maps, tables,
and charts, you have the tools you need for further studies.

Step 10 Close the project

From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.
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Self test

(2) You can get summary statistics for any set of records in a table.
c True
& False

(2) The Query Builder button on the table interface works the same as the Query Builder
button on the view interface.

# True
e False

{3) You can select multiple records with the Select Record too!.
¥ True
e False

{4) When you get summary stafistics for a set of records, the results are placed in a new
tabla.

(5) You can create a summary table only from numeric fields in a table.

c True
¥ False

{6) To get statistics for a set of records, first you need to:

e Select the themse

e Make the field that you want stalistics for the active field
c Create a summary table

c Choose Summarize from the Field menu

(7) A chart can display only one attribute field for a set of records.
e True

c False

Working with fields and records

There are a variety of ways to edit tables in ArcView. You can give fields altemate
names, specify which fields display, alter the display width of fields, and add and
delete fields. Tabular data doesn't have to be in a theme attribute table for you to edit
it. ArcView supports many table formats,
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4.3 Modify fields
For this exercise, you will calculate population density for each of the provinces in

Syna,

Estimated time to complete: 15 minutes

Step 1 Start ArcView and open the project

If  necessary, start  ArcView. Next, open the project in
introavitables\lesson02\L02_ex01.apr. When the project opens, you see a view with
one active theme, Population.shp. This theme shows the population figure and area in
square kilometer for each of the provinces in Syria.

Step 2 Open the theme attribute table

Open the attribute table for the theme by clicking the Open Theme Table button
on the view button bar. Examine the fields in the table by scrolling to the right. By
default, all fields in the table are visible; however, you may not be interested in all of
them. For example, the Shape, Area, Perimeter fields in this table may not contain
information that's useful for your calculation. You will hide these fields so they don't
appear in the table.

Step 3 Open the Table Properties dialog

With the table active, choose Properties from the Table menu. The Table Properties
dialog displays with a list of field names and a column indicating which fields in the
table are visible.

Step 4 Hide fields

Click on the checkmarks next to the following fields to tum them off and make them
invisible: Shape, Area, Acres and Perimeter. In the Alias column, type in Regional
pame for the region_nam, Population in 1994 for Pop-94 and Area (square
kilometer) for the Area-km2.

Step 5 Apply your changes
Click OK and see changes you made. Notice that you can't see the complete names
for some of these fields because the fields are too narrow. Next, you will widen them.

Step 6 Widen the fields' display

Position your mouse pointer over the field divider (the vertical line to the right of the
field name) for the Area (square kilometer) field until it becomes a two-headed
arrow. Drag to the right to widen the field so that the entire name displays. Do the
same for the other fields you want, Afier you resize a field, the new display size is
saved when you close the table or the project that contains it. The next time you open
the table, ArcView displays the field at the saved size. Now that you have hidden
fields, assigned more meaningful field aliases, and widened fields, the data is tailored
to your project. In the next exercise, you'll add a new field to the table.
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Step 7 Start editing the table

Before you add a field to the attribute table, you must enable editing. With the
Attributes of Population.shp table active, from the Table menu, choose Start
Editing. Notice that the field names in the table become non-italic when editing is
enabled.

Step 8 Add a field
From the Edit menu, choose Add Field. The Field Definition dialog box displays.
This is where you define the properties of the new field. In the Name field type
Pop_density. The new field will be a number field, and the default values for Type
and Width are correct but for Decimal Places Type 4. Click OK. The new field is
added to the table.

Step 9 Calculate values for the new field
Now you'll calculate the values for the new field. Make the new field active. Click the

Calculate button to display the Field Calculator dialog box. This is where you
define the mathematical expression that ArcView will use to calculate values for the
active field. The new field will hold value for the population density for each province
(population divided by area).

Step 10 Enter a mathematical expression

In the Fields list, double-click on [population in 1994]. In the Requests list, double-
click on the / sign. Finally, in the Fields list, double-click on [Area (square
kilometer]. Your mathematical expression displays in the text box (lower left) as you
define it. Click OK to have ArcView calculates the values for the new field.

Step 11 Save the edits

From the Table menu, choose Stop Editing. Click Yes when asked to save your
edits. Notice that the field names redisplay in italics to indicate that they are not
editable. By adding a new field and calculating new values for this field, you've
isolated the data you need for your project. In the next exercise, you'll generate
statistics and new data for the project.

Step 12 Close the Project
From the File select Close All - Close Project When prompted to save the project
say No.

Self test

{1)You can change a field's display width using the mouse.
> True
e False
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{2) You cannot make fields invisible in ArcView.

(3) You can genserate summary statistics for afl the records in a table.
& True
e False

(4) You must define the number of decimal places when adding a numeric field to a table in
ArcView.

C True
c False

(5) Which dialog allows you to add or modify field values using an expression?
c Query Builder

c Field Calculator

c Statistics window

c Table Properties

(6) To edit a table you need to:

C Choose Table Editor from the View menu

C Choose Start Editing from the Table menu

c Click the Query Buildsr button on the Table interface
c Choose Edit Table from the Table menu

(7) In a theme attribute table, each of these represents a feature.
e Point

c Record

C Column

C Field

Accessing tables

Ofien, you have additional information about features that is not contained in a
theme's attribute table. The data may be in other tables or text files. You can access
such data by joining or linking to the source file. After you access the data, you can
perform operations on it just like you can do with data contained in a theme attribute
table. You can also create connections to external files of any format, including
images, to enhance your ArcView projects In ArcView, you can combine, or join,
tables and work with them as if they were one. ArcView's Join function uses the
values in a common field 10 match the records in both tables. The fields do not have to

52




be named the same, but they must be of the same field type (i.e., number, string, date,
or Boolean) for the join to work.

4.4 Join tables

For this exercise, suppose you're working on a project that involves using weather
data. In your search for weather data to be used, you were given 2 files containing
required data. You will join these files together and view the information using
Arcview.

Estimated time to complete: 20 minutes

Step 1 Start ArcView and open the project

If necessary, start ArcView, and open the project
introav\tables\lesson03\L03_ex01.apr. When the project opens, you'll see a view of
the outline of Syria boundary and a point theme of weather stations in Syria.

Step 2 Add a table to the project
You'll add a table containing weather data of these stations to the project then join it
to the theme (weather-stations.shp) attribute table. Make the Project window active.

With the Tables icon selected, click the Add button to display the Add Table
dialog. On the dialog, navigate to \introavtables\lesson3\ and select
weather_data.dbf file.

Step 3 Examine a table information

Click OK to add the weather_data.dbf table to your project. When the table opens,
notice that the first field contains the names of the weather stations. This is the same
with the name in the attribute table. You'll use this field to join the two tables. Joining
tables allows you to attach tabular data to the themes in a view. In this exercise, when
you join the data in the weather_data.dbf table to the data in the theme attribute
table, weather_data.dbf is the source table and the theme attribute table is the
destination table (the table to which fields are appended). Tables are joined based on
a field that is common to both tables; in this case, Station.

Step 4 Prepare to join tables

To see both tables during the join, you'll reposition them. Move the weather_data.dbf
table to the upper left comer of the ArcView window. Click on the Station field to
make it active. Now make the theme table (Attributes of Weather_stations) active,
Move it to the lower right corner of the ArcView window. Scroll to the Station field
and click on it to make it active.

Step 5 Join the tables

Click the Join button ArcView appends the fields in the weather_data.dbf table
to the theme attribute table and closes weather data.dbf. Records in the theme
attribute table have a one-to-one relationship to records in the weather_data.dbf table.
That is, for each weather station in the theme attribute table, there is only one record
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of weather data value. Scroll to the right in the table and notice that it now contains
fields from the weather_data.dbf table.

Step 6 1dentify a feature

Click the Identify tool then click on any point in the view to display its attributes
in the Identify Results window. You'll see now that the attribute table has more fields.
When you're finished, close the Identify Results window.

Ste7 Close the project
From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.

Self test

(1) Joining tables is appropriate when the records in one table have a one-to-many
relationship with records in the second table.

e True
E False

(2) After joining two tables, you can usse the Identify tool to get attribute information from both
tables.

c True
|

False

(3) After linking two tables, you can use the Query Builder to select records in both tables.
c True

e False

(4) You can use the data in two separate tables by linking the tables.

(5) When there is one record in a table that maiches to one record in a second table, what
type of relationship do the records in the two tables have?

E Many-to-many
C One-to-many
c

& One-to-one

Many-to-one
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Exercise 5
Querying features

Spatial query is the process of selecting features based on their geographic
relationship, or spatial relationship, to other features. For example, you might be
interested in finding out which features are within a certain distance of other features,
which are adjacent to other features, which are contained inside other features, or
which intersect other features. In ArcView, you can perform spatial queries using
features from different themes. The process of overlaying one theme with another in
order to determine their geographic relationships is called spatial overlay.

5.1 Find features nearby

For this exercise, one of the criteria for selecting sites for a proposed project’s survey
are districts (Nahia) where there are no major towns (urban areas) within 20 km in
Syria. Your task is to identify these district areas.

Estimated time to complete: 20 minutes

Step 1 Start ArcView and open the project

Start ArcView, and open the project introav\analyze\lesson01\L01_ex01.apr. When
the project opens, you see a view with two themes: a point theme called Urbanized-
areas and a Polygon theme called Syria-nahia. The Syria-nahia theme is active.
You'll use this feature to select district areas within 20 Km of urbanized areas. The
Syria-nahia theme is the target theme while the Urbanized-areas theme is the selector
theme.

Note: The target theme must be active to perform a theme-on-theme selection.

Step 2 Open the Select By Theme dialog

From the Theme menu, choose Select By Theme. Select By Theme dialog box will
displays. This dialog is where you specify the type of spatial relationship you want to
analyze with theme-on-theme selection. ArcView supports these types of spatial
relationships: Are Completely Within, Completely Contain, Have their Center In,
Contain the Center Of, Intersect, and Are Within Distance Of. Theme's feature type
determines what types of spatial relationships you can analyze; you'll choose the
selector theme first.

Step 3 Specify the spatial query

In the Select By Theme dialog, select Urbanized-areas in the lower dropdown list (if
it's not already selected). Choose Are Within Distance Of in the top dropdown list.
Type 20 in the Selection distance field. (The distance is in km because the map units
are set to km in this view).
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Step 4 Create the selection
Click New Set. ArcView finds all Nahia within 20 km of the urban areas of Syria,
The opposite of this selection is what you want. You will now select this.

Step 5 Reverse your selection
With the Syria-nahia theme active, open the table by clicking Open Table tool .

Click on Toggle Records tool. The Records selected now are all Nahia that have
no urban areas within 20 km.

Step 5 Check the result

Click on the Promote tool @ If you look at the last row of Button’s bar, 94 out 210

is diplayed. It means 94 out of 210 districts in Syria have no urban areas within 20
km.

Step 6 Close the project

You've seen how theme-on-theme selection can be used to support real decision-
making, In only a few moments, you found districts in Syria that meets your criteria.
From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.

5.2 Find adjacent features

ArcView can find features adjacent to a specific feature or features you select.
Suppose you are part of a team mapping areas vulnerable to disasters. One of the hot
spots for this mapping is the fault zone. Your task is to identify all the fault zones of
Syria and list all districts adjacent to any of these zones. You are also required to find
total areas of districts under fault zones,

Estimated time to complete: 15 minutes

Step 1 Start ArcView and open the project

Start ArcView if necessay, and open the project
introav\analyze\lesson01\L01_ex02.apr. When the project opens, you will see a
view with two themes, Faults and Syria-districts. The Syria-districts theme is active.
You're now ready to find out all districts in Syria that are adjacent to fault line.

Step 2 Define the selection
From the Theme menu, choose Select By Theme to display the Select By Theme
dialog. Choose Faults in the lower dropdown list if it's not already selected. Choose

Are Within Distance Of in the top dropdown list. Type 0 in the Selection distance
field.

Step 3 Create the selection

Click New Set. ArcView selects districts adjacent to the fault line. To find out how
many districts are selected, you'll open the theme table. Click the Open Theme Table
button. Click the Promote button to move the selected records to the top. Looking at
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the status bar to the left of the toolbar, you can see that the 27 out of 210 districts in
Syria are adjacent to any of the fault zone. Next, you will answer the second question,
what is the total area of districts under fault zone?

Step 4 Find the total area

In the Attributes of Syria-districts table, click on the Area field to make it active.
Click the Field Menu and select Statistics. A dialog box displays which shows the
sum of area of the selected districts “Sum: 49922.065". That is, total areas of Syria

adjacent to fault line is 49,922.065 km*

Step 5 Close the project
From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.

Self test

(1) The process of superimposing layers (themes) of geographic data that occupy the same
space in order to study the relationships between them is called:

c Graphic ovemplot
C Spatial overlay
c Selection orientation
c Object selection

(2) A proximity query finds features that are within a specified distance of other features.
True
c False

(3) When performing theme-on-theme selection, what is the theme whose features will be
used to select other features called?

c The target theme
c The selector theme
c The analysis theme
e The object theme

(4) The spatia relationship in which features are completely within a polygon feature is called
containment.

c True
e False
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(5) Whsn performing theme-on-theme selection, to find adjacent features, which option would
you choose to complete the "Select features of active theme that...” portion of the selection
statement?

c Are within a distance of
c Intersect

e Share common boundary
c Are within

5.3 Find intersecting line features

Suppose that a vuinerability mapping carried out in a community shows that there are
lots of earthquake faults. Consequent to this, a committee was set up to develop a plan
to deal with potential flooding and health risks associated with the rupture of water
and sewer lines in the event of a major earthquake. As the first step in the study, the
committee is expected to use ArcView GIS to find those water and sewer pipelines
that intersect earthquake faults. As a member of the committee and who knows how
to use ArcView GIS, you were asked to camry out this task.

Estimated time to complete: 20 minutes

Step 1 Start ArcView and load the project

If necessary, start ArcView, and open the project
Introav\analyze\lesson02\L.02_ex01.apr. When the project opens, you see a view
with two themes, Pipclines and Faults. To find out which pipelines intersect faults,
you'll use theme-on-theme selection. The Pipelines theme is the target theme while
the Faults theme is the selector theme. The target theme must be active to perform a
theme-on-theme selection. Features in this theme will be used to select features in the
Pipelines theme.

Step 2 Create the spatial query

Make the Pipelines theme active. From the Theme menu, choose Select By Theme.
The Select By Theme dialog will display. In the lower dropdown list, choose Faults.
In the upper dropdown list, choose Intersect. Your selections form this sentence:
"Select features of active themes that intersect the selected features of Faults.”

Step 3 Create the selection

Click New Set ArcView selects pipelines that intersect faults. Now that the vulnerable
pipelines are selected, the committee wants to determine their total number and length
so they can estimate potential repair and replacement costs.

Step 4 Examine the selected features

With the Pipelines theme active, click the Open Theme Table button. The Attributes
of Pipelines table opens. To see the selected records better, you will promote them.
Click the Promote button. Records for the selected pipelines now appear at the top of
the table. Next, you'll use the Summarize function to calculate the total number and
length of these pipelines according to owner.
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Step 5 Open the Summary Table Definition dialog

In the Attributes of Pipelines table, scroll to the right and click on the Owner field
name to make it active. ArcView will use the unique values in this field to summarize
the selected records in a new table. Click the Summarize button. The Summary
Table definition dialog box opens.

Step 6 Define the summary table

In the Field dropdown list, choose Length. In the Summarize by dropdown list,
choose Sum. Click Add. Your selection is added to the summary statistics box on the
right. Click the Save As button and navigate to your c:\temp directory. Type
pipe_length.dbf for the filename. Click OK to accept the filename.

Step 7 Create the summary table

Click OK to create the summary table. ArcView creates one record for each unique
owner it finds. The new table shows there are five owners of the selected pipelines.
The Count field reports the total number of pipelines for each owner, and the
sum_Length field lists their total length. You can now give this information to the
committee as the starting point for working with the responsible agencies to develop a
plan to deal with potential flooding and health risks.

Step 8 Close the project
From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.

5.4 Find polygons that intersect other polygons

Like earthquakes, floods require emergency planning and special programs for human
and property protection. Legislation requires communities in flood-prone areas to
participate in flood insurance programs. These programs, aimed at protecting property
owners, require owners to purchase flood insurance at government-subsidized rates.
As a participant in a flood insurance program, one city located on a major floodplain
developed a database containing the boundaries of 100-year and 500-year flood zones.
(These zones are expected to flood at least once during the designated time span.) The
city wants to notify all property owners within the 100-year zone about special low-
cost loans for elevating structures above the base flood level, thereby cutting
insurance costs. Using ArcView's theme-on-theme selection functionality, the city can
determine which land parcels are located within the 100-year flood zone and then
notify the owners about the loan program.

Estimated time to complete: 15 minutes

Step 1 Start ArcView and open the project

Start ArcView, if necessary, and open the project
introavianalyze\lesson02\L02_ex02.apr. When the project opens, you see a view
with two themes: Floodzones and Parcels. The 100-year flood zone is selected in the
Floodzones theme. To see all the features in both themes, you'll zoom out.
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Step 2 Create the spatial query

Click the Zoom to Full Extent button E3. Next, you'll find out which parcels
intersect the 100-year flood zone. Make the Parcels theme active so that it is the
target theme. From the Theme menu, choose Select By Theme. In the lower
dropdown list, choose Floodzones to make it the selector theme. In the upper
dropdown list, choose Intersect. Your selections form this sentence: "Select features
of active themes that intersect the selected features of Floodzones."

Step 3 Create the sclection
Click New Set. ArcView selects parcels that intersect the 100-year flood zone.
To see the selected parcels better, you'll tum off the Flsodzones theme.

Step 4 Redraw the parcels theme

In the Table of Contents, click the Check box next to the Floodzones theme to tumn
it off. ArcView redraws the Parcels theme. Next, you'll open the theme table and
examine the selected records.

Step 5 Examine the results

With the Parcels theme active, click the Open Theme Table button. Click the
Promote button to display the selected records at the top of the table. Scroll to the
right to examine the attributes. The parcel attributes include assessor’s parcel number,
zoning codes, General Plan codes, acreage, owner name, owner address, and more.
The city now has a list of all parcels that would be affected by a 100-year flood as
well as the information it needs to contact the owners about the special loan program.

Step 6 Close the project

From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes. If you want to go on
to the next lesson, leave ArcView running. Otherwise, choose Exit from the File menu
to close ArcView.

Self Test

(1) ArcView cannot determine where line features and polygon features intersect.
c True
c False

{2) In ArcView, you can find line features that intersect polygon features but you cannot find
polygon features that intersect line features.

c True
e False
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(3)f there are selected features in the selector theme, they will be used to select features in
the target thems when performing theme-on-theme selection.

e True
c False

(4) You can use theme-on-theme selection to find polygon features that intersect other
polygon features.

e True
c False

(5) It doesn't matter if you select features using lines or polygons as the selector theme; you'l
still get the same number of selected features.

e True
(¥ Faise

(6) By default, if features in the selector theme are selected, how many of the selector
theme's features are used for theme-on-theme selection?

e 0

e 1

e All the selected features

C All the features in the theme

(7) To find overlapping polygons, you would choose this option in the Select By Theme dialog.
c Intersect

e Are Adjacent To

C Overlap

c Within a distance of (using -1 as the distance)

Finding features and joining their attributes

When you use theme-on-theme selection, ArcView uses the features in one theme to
find features (and their attributes) in another theme. The selected features and
attributes remain in separate theme tables. In a spatial join, however, ArcView GIS
appends the fields of one theme table (the source table) to those of another theme
table (the destination table) using the geographic locations of the features. The result
is one theme table containing data on features in both themes.

5.5 Join attributes based on containment

Suppose you're a wildlife biologist studying water sources on protected lands, such as
national parks, national forests, and wildlife reserves. When water sources become
scarce during the dry season, wild animals in these areas often migrate to grazing
lands that support livestock. You'd like to anticipate this situation and take measures
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to prevent it. To do so, you'll need to know how many water sources each area has.
You'll perform a spatial join to append the attributes of these areas to the water
sources found within them. Then you'll create a query to find the water holes that are
inside protected areas and summarize their attributes to find the number of water
holes in each protected area.

Estimated time to complete: 25 minutes

Step 1 Start ArcView and open the project

If necessary, start ArcView, and open the project
Introav\analyze\lesson03\L03_ex0l.apr. When the project opens, you see a view
with two themes, Water Holes and Range. Features in the Range theme are divided
into three classes: Unprotected Areas, Protected Areas, and Unknown. You want to
know the characteristics of the area each water hole lies in, so you'll join the attributes
of the Range theme to those of the Water Holes theme.

Step 2 Open the theme attribute tables

With the Water Holes theme active, hold down the Shift key and click on the Range
theme to make both themes active. Click the Open Theme Table button to open the
attribute tables for both themes. In this case, Attributes of Range is the source table
and Attributes of Water Holes is the destination table. The destination table is the one
that's active when you perform the join.

Step 3 Make the Shape field active in each table

In the Attributes of Range table, click on the Shape field to make it active. Now move
the Attributes of Range table out of the way and make the Attributes of Water Holes
table active. Click on the Shape field in the Attributes of Water Holes table. The
Shape field is common to both tables, and you have selected it in both tables.

Step 4 Join the tables

With the Attributes of Water Holes table active, click the Join button (3]

ArcView joins the Attributes of Range table to the Attributes of Water Holes table
based on the location of features in the two themes. Widen the Attributes of Water
Holes table so you can see more fields. The Attributes of Water Holes table
(destination table) now has fields appended from the Attributes of Range table (source
table). For each water hole, there is now a range code (Rcode) and description. Water
holes with a range code of 6 are located in national parks, forests, and reserves. You'll
build a query to select them. In a spatial join, you join two theme tables by using the
Shape field as the common field. For each feature in the first theme, a corresponding
feature in the second theme is found that satisfies one of these spatial relationships:
nearest or inside. In this case, ArcView uses the inside relationship to find the range
area that each water hole lies in. The attributes of the range are then appended to the
attributes of the water hole. If there is more than one water hole in a range area, the
attributes of that area are appended to each water hole.
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Step 5 Open the Query Builder
Make the view active. Both themes (Water Holes and Range) are active. Click on the
Water Holes theme to make it the only active theme. Click the Query Builder button

to open the Query Builder dialog.

Step 6 Select the water holes

Make sure the Update Values check box is checked. In the Fields list, double-click
[Reode]. Click the equals sign (=) button. Double-click on 6 (national parks, forests,
and reserves) in the Values list. Click New Set to select all the water holes in the
national parks, forests, and reserves. Close the Query Builder dialog box. You see
the selected water holes highlighted in yellow in the view. To see the attributes of the
selected water holes, you'll open the theme table.

Step 7 Examine the selected records

Click the Open Theme Table button and click the Promote button to move the
selected records to the top of the table. You may need to widen the table or scroll to
the right to see all the fields. Next, you'll summarize the selected water holes based on
the values in the Description field to determine the number of water holes in each
park, forest, and reserve.

Step 8 Define a summary table

In the Attributes of Water Holes table, click on the Description field to make it
active. From the Field menu, choose Summarize (or click the Summarize button).
The Summary Table Definition dialog opens. Click the Save As button and navigate
to your \temp directory. Type in watdes.dbf as the filename. Click OK to accept the
filename.

Step 9 Create the summary table

Click OK to create the summary table. ArcView creates one record for each park,
forest, and reserve that's named in the Description field. The Count field lists the
number of water holes in each one. Now you know which protected areas have water
sources and how many sources are in each area. You can study these sources to find
out which can support local wildlife throughout the dry season and which cannot.

Step 10 Close the project
From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.
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5.6 Join attributes based on proximity

As a way of raising money to maintain protected areas, the government would like to
sponsor camera safaris to water holes in those areas. Your job is to evaluate access to
the water holes. You've discovered that only one of four protected areas is accessible
by land. The other three are too remote. As an alternative, the government would like
to fly tourists into these areas. You'll need to know how far each water hole is from
the nearest landing strip. Because tourists will have to travel over bumpy, unimproved
roads to get from landing strips to water holes, you want to find those water holes
within 20 kilometers of a landing strip to minimize driving time. To find those water
holes, you'll perform a spatial join to append the attributes of landing strips to the
water holes found nearest to them. ArcView calculates the distance from each water
hole to the nearest landing strip and, in a field called Distance, appends this
information to each water hole. You'll perform a query on this field to find out which
water holes are located less than 20 kilometers from a landing strip.

Estimated time to complete: 20 minutes

Step I Start ArcView and open the project

Start ArcView and open the project introavianalyze\lesson03\L03_ex02.apr. When
the project opens, you see a view with three themes: Airports, Water Holes, and
Range. In the Range theme, the three remote protected areas are labeled. The Water
Holes theme shows only the water holes inside these protected areas. The Airports
theme (active) shows all the landing strips for the entire region.

Step 2 Open the theme attribute tables

With the Airports theme active, hold down the Shift key and click on the Water
Holes theme. Now both themes are active. Click the Open Theme Table button to
open the theme attribute tables for both themes.

Step 3 Join the tables

In the Attributes of Airports table (source table), make the Shape field active. Also
make the Shape field active in the Attributes of Water Holes table (destination table).
With the Attributes of Water Holes table active, click the Join button to join the
Attributes of Airports table to the Attributes of Water Holes table. ArcView uses the
nearest relationship to find the landing strip closest to each water hole. Scroil to the
right in the Attributes of Water Holes table to see all the fields. The attributes of the
landing strip (Id) are appended to the attributes of the water hole. ArcView also
calculates the distance between each water hole and the closest landing strip and
places this value in a field called Distance. (This data is in UTM meters so the results
from the spatial join are also in meters). Whenever ArcView uses the nearest
relationship in a spatial join, a distance field is added to the joined table. Next, you'll
build a query to find the water holes that are less than 20 kilometers from a landing
strip.

65




—

Step 4 Create a query

With the Attributes of Water Holes table active, click the Query Builder button to
open the Query Builder. Double-click [Distance] in the Fields list. Click the less than
sign (<) button. Type in 20000 for the query field.

Step 5 Create the selection

Click New Set to select all the water holes that are less than 20 kilometers from a
landing strip. Close the Query Builder. Click the Promote button to move the
selected records to the top of the table. Now you know which water holes are closest
10 landing strips. These sites meet your criteria for good camera safari sites. You want
to evaluate the remaining (unselected) sites for future development, however, so you'll
change the selected set to water holes that are more than 20 kilometers away from
landing strips.

Step 6 Switch selections

Click the Switch Selection button @ to select the water holes that are more than 20
kilometers away from a landing strip. Promote the selected records to the top of the
table by clicking the Promote button. The highlighted records are water holes that are
more than 20 kilometers from a landing strip. When you use the Switch Selection
button, ArcView changes the selected set of records to the previously unselected
records. If the records belong to a theme table, the selected and unselected sets of
features in the theme are also switched in the view. If no records are selected, using
the Switch Selection button will select all the records.

Step 7 Examine the view

Make the view active, Water holes more than 20 kilometers from landing strips are
highlighted. These water holes can be developed for future safaris by adding new
landing strips or by improving the roads leading from them to the nearest existing
landing strip. ArcView helped you meet your initial objective of evaluating access to
water holes. You know how far each water hole is from the nearest landing strip,
which ones are within 20 kilometers of existing landing strips, and which ones aren't.
If the camera safari project is successful in raising revenues for protected areas, both
the local economy and the protected areas will benefit.

Step 8 Close the project
From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.

Self test

(1) A spatial join appends attributes from one theme attribute table to another theme attribute
table.

e
c

True

False
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{2) In a spatial join, attributes are assigned to the active table's records based on the
geographic locations of the themes' features.

e Truse
& False

(3) To perform a spatial join comectly, you must have the appropriate thems table activa.

(5) When you use spatially join two point themes, ArcView adds a new field named:
e Shape

E 16

& Length

c Distance

(6) Which fisld is used in a spatial join operation as the common table field?

E 1ype

e Point

c Location

e Shape

{7) The two types of spatial joins are Nearest and:

c Inside

c Farthest

C Distance

> Adjacency

Advanced geoprocessing

ArcView GIS comes with an extension called Geoprocessing tools. It is very useful to

create a buffer and overlay data using the merge, dissolve, clip, intersect, and union
functions. You’ll use this tool in doing exercises in this section.
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5.7 Perform advanced geoprocessing

How a city's land is used affects all who live there. If a city has many areas dedicated
to industry, smog and noise pollution can negatively affect the quality of life for the
city's residents. City parks and open spaces, like vacant lots or ravines, can help make
a city more beautiful and offset the effects of noise and air pollution. In this exercise,
you'll investigate areas within a 300-meter buffer of industrial sites in one of the cities
in the world. You'll analyze these areas to see what types of land uses exist there.

Estimated time to complete: 30 minutes

Step 1 Start ArcView and open the project

Start ArcView and open the project introav\analyze\lesson04\104_ex01.apr. When
the project opens, you see a view called City that contains two themes: Parks and
Landuse.

Step 2 Set the view's background color

From the View menu, choose Properties. In the View Properties dialog, you'll see
Background Color alongside a box that shows the current color of the view's
background. Right now, the box has an X through it to show that no color is being
used for the background. Click Select Color to display then Color Picker. Click on
the Black square and click OK_ Notice that the box in the View Properties dialog is
updated to display the color that you chose. Click OK in the View Properties dialog to
apply the color to your view.

Step 3 Change the Table of Contents style

From the View menu, choose TOC style. This displays the Table of Contents Style
Settings dialog that you can use to change the look of your Table of Contents (TOC)
in all your views.

In the Line Flatness dropdown list, choose Flat.

In the Symbol Length dropdown list, choose Normal.

For Font, choose Times New Roman.

For Style, choose Bold Italic.

For Size, choose 10.

Click Apply. The TOC is updated with your new settings. If you like, take some time
to experiment with different settings to see how it affects the look of your TOC. When
you are finished, click Close.

Step 4 Load the Geoprocessing extension

Before you do any processing, you'll need to load the Geoprocessing extension, From
the File menu, choose Extensions. In the Extensions dialog, check the box next to
Geoprocessing. Click OK.
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Step 5 Simplify Landuse.shp with Dissolve
Geoprocessing can take a lot of time if your theme has many features. Make Landuse

the active theme and click the Open Theme Table button Notice that Landuse
has 12,876 features. Scroll to the right and find the DESC field. Landuse is classified
into nine categories, which are stored in the DESC field. These values are used to
symbolize Landuse in the view's TOC. By using Dissolve, you can reduce the number
of features from 12,876 to nine—-one feature for each landuse class in the theme. With
fewer features to process, subsequent geoprocessing tasks will take less time. This is a
good technique to use when you're working with themes consisting of many features,
Close the Attributes of Landuse table.

Step 6 Open Geoprocessing Wizard

From the View menu, choose GeoProcessing Wizard. The first panel of the
GeoProcessing Wizard displays the geoprocessing tools you can access with the
wizard. The first tool you'll use is Dissolve. Choose Dissolve option to dissolve
features based on an attribute and click Next. The second panel lets you choose the
theme with features you want to dissolve and the attribute to dissolve. Choose
Landuse as the theme you want to dissolve. For the attribute to dissolve, choose Desc

in the dropdown list. Specify the output file by clicking the Browse button J and
navigating to your introavianalyze\lesson04 folder. Name the ouput file land_disslv.
Click OK. Click Next then click Finish. The Dissolve process may take a few
moments. When it finishes, a new theme called Land_disslv.shp is added to the City
view.

Step 7 Examine the new theme

Make Land_disslv.shp the active theme and click the Open Theme Table button.
Notice that the Attributes of Land_disslv.shp table now contains only nine records.
All polygons belonging to the same DESC class now share a single record in the
attribute table. You can see how many polygons are represented by each class by
looking at the Count field. For instance, there are 119 polygons with a DESC value of
Agriculture, all of which now share the single record in the table. Close the Attributes
of Land_disslv.shp table.

Step 8 Symbolize Land_disslv.shp

Because Land_disslv.shp is a simplified version of Landuse, you'll use it for the rest
of the analysis in this exercise. Right now, it's symbolized with a single symbol. A
legend file called landuse.avl has already been created for you to use with
Landdiss.shp. Before continuing with the exercise, you'll apply this legend to
Landdiss.shp. In the TOC, check the box next to Land_dislvs.shp to turn the theme
on. Doubleclick on Land_dislvs.shp to open the Legend Editor. Click Load. In the
Load Legend browser, navigate to your introavianalyze\lesson04 folder and click on
landuse.avl. Click OK. In the Load Legend dialog that appears, make sure the Field
dropdown list says Desc, Click OK. In the Legend Editor, click Apply then close
Legend Editor. In the Table of Contents, move Parks to the top so that the order of
themes from top to bottom is: Parks, Land_dislvs.shp, Landuse. Turn off Landuse.
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Step 9 Update the Area and Perimeter fields

When you execute any of the geoprocessing tools, ArcView doesn't automatically
update the result theme's area and perimeter fields (for polygon themes) or the length
field (for line themes). You need to update these values using the Avenue script
Calcapl.ave. Calcapl.ave has already been added to this project. Make the Project
window active and click the Scripts icon. Click Open to open Calcapl.ave. The script
requires Land_dislvs.shp to be active. From the Window menu, choose City. In the
view, make Land dislvs.shp the active theme. Next, from the Window menu, choose

Calcapl.ave to make the script window active again, then click the Run button .

Note: When you run a script in ArcView GIS, the order of your actions is very
important. For Calcapl.ave to work correctly, the view window must be the last
active window before the script is run.

Now make the City view active once again. Open the Land_dislvs.shp theme table.
Notice that Area and Perimeter fields have now been added to the table. It is
important to keep the Area field up-to-date because you'll eventually use this field to
find out how much green space and residential areas exist near industrial sites. Close
the Attributes of Land_dislvs.shp table.

Step 10 Sclect industrial sites

The first step in finding the green spaces and residential areas near industrial sites is
to find all the areas within a certain distance of the industrial sites. You can find these
areas by buffering or using theme-on-theme selection. Because the objective is to find
out how much of the area is green space (parks, vacant lots, and ravines) and how
much is residential, you'll use a buffer. Buffering gives you more precise results than
theme-on-theme selection. With a buffer, you can find the exact areas within a certain
distance of the industrial zones. Theme-on-theme selection (with the Within A
Distance Of option) won't find these areas because it doesn't create new features at the
boundary of the distance specified. If you select some features before opening the
Create Buffers wizard, you can choose to buffer just the selected features or all the
features in the theme. To buffer only the industrial sites, you must first select them.

With Land_dislvs.shp active, click the Query Builder button . Make sure the
Update Values check box is checked. In the Fields list, double-click on [Desc]. Click
the equals sign button (=). In the Values list, double-click on Industrial.

Step 11 Examine the table

Click New Set and close the Query Builder. Examine the highlighted areas in the
view. These are the industrial sites that you'll be buffering in the next step. Click on
the Theme menu. Notice that the Create Buffers option (second from the bottom) is
grayed-out and not available. This is because you must set the view's map and
distance units before ArcView GIS can calculate a buffer. From the View menu,
choose Properties to display the View Properties dialog. The City dataset is
projected to State Plane-Feet so set the Map and Distance Units to feet. Click OK.
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Step 12 Buffer the industrial sites

In this step, you'll find the areas around the selected industrial sites by creating buffers
that extend to 300 meters. By finding the total area covered by the buffer polygons,
you'll have found the total area within 300 meters of the industrial sites of City. While
you're working through the Buffer Wizard, you can check your settings at any time by
clicking Back to retumn to a previous panel. The buffers will not be created until you
click Finish. From the Theme menu, choose Create buffers to display the first panel
of the Buffer Wizard. Choose the option Buffer the features of a theme. In the
dropdown list, choose Land_dislvs.shp as the theme to buffer. A checkmark appears
at the bottom indicating that you will use only the selected features of
Land_dislvs.shp. Click Next to apply these options. In the second panel of the Buffer
Wizard, choose the option Create the buffers at a specified distance of 300. Change
the Distance units to Meters in the bottom dropdown list. This will create buffer
areas 300 meters around all industrial sites in Land_dislvs.shp. Click Next to display
the final panel of the Buffer Wizard. Click Yes to dissolve barriers between buffers.
Choose the option Create buffers so they are only outside the polygon. Save the

buffers in a new theme. Click the Browse button and navigate to your
introav\analyzeMlesson04 folder. Keep the default filename buffl.shp. Click OK. It
may take a few moments for ArcView to process the buffers. When the process is
complete, the buffers are created in a new theme called Buffer] of Land_dislvs.shp.
Notice that the buffer zones cover the areas you are interested in. In the next step,
you'll change the symbol used to display the buffers so that you can see the
underlying data

Step 13 Change the buffer's symbology

With Buffer1 of Land_dislvs.shp active, from the Theme menu, choose Properties.
Change the name of Bufferl of Land_dislvs.shp to Buffer of Industry. Click OK.
Double-click on Buffer of Industry to display the Legend Editor. In the Legend
Editor, double-click on the Symbol to open the Symbol Window. In the Symbol

Window, click Fill Palette button . Click the first symbol (top left square) and in
the Qutline dropdown list, choose 2. This will make the width of the outline thicker

and easier to see. In the Symbol Window, click the Color Palette button In the
Color dropdown list, choose Outline. Click on a bright yellow square. The symbol is
updated in the Legend Editor. In the Legend Editor, click Apply. Now you can see the
selected industrial sites as well as the extent of the 300-meter buffer around these
areas. Close the Legend Editor and the Symbol Window.

Step 14 Clip Land_dislvs.shp with Buffer of Industry

To calculate the area of the city that falls within the 300-meter buffer zone, you'll clip
Land_dislvs.shp using the buffer theme. This will create a theme containing only
those landuse areas that fall within 300 meters of industrial sites. Because you no
longer need the selected set of industrial sites, you'll clear the selected industrial
features in Land_dislvs.shp. Make Land_dislvs.shp active and click the Clear

Selected Features button The clip operation is a part of the Geoprocessing
extension. To access it, from the View menu, choose GeoProcessing Wizard.
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Choose the option Clip one theme based on another and click Next. For the input
theme to clip, choose Land_dislvs.shp in the dropdown list. For the polygon overlay
theme, choose Buffer of Industry in the dropdown list. For the output file, click the

Browse button and navigate to your introavianalyze\lessson04 folder. Name the
new shapefile Area_total.shp. Click OK. Click Finish. The clip process may take a
few moments. ArcView reports on the processing in the status bar (in the lower-left
comer of the ArcView window). When the process is complete, a new shapefile
called Area_total.shp is added to the view. Tum it on. The area covered by
Area_total.shp represents all the areas in City that are 300 meters from the industrial
sites.

Step 15 Update the Area and Perimeter fields

When you clip a theme using another theme, new shapes are created in the output
theme. The new shapes need to have their Area and Perimeter fields updated. Make
Area_totalshp active and open its theme attribute table. Notice that all the polygons
have the same values for Area and Perimeter. Close the Attributes of Area_total.shp
table and make the City view active. Make Area_total.shp the active theme if it isn't
already. To calculate the proper areas, you'll run the script called Calcapl.ave. Make

the Calcapl.ave script window active. Click the Run button L&J to run Calcapl.ave. In
the Calculate dialog that appears, click Yes to update the Area field and the Perimeter
field. Make the City view active and open the Area_total.shp theme table. The Area
and Perimeter field now contain the correct values.

Step 16 Summarize Desc to find the total areas
To find out how much area is Residential and how much is Green Space, you'll
summarize the Desc field. In the Attributes of Area_total.shp table, click on the Desc

field name so that it is the active field. Click the Summarize button to open the
Summary Table Definition dialog. In the Field dropdown list, choose Area. In the
Summarize by dropdown list, choose Sum. Click Add then click OK. A summary
table called sum1.dbf is created. By looking at this table, you can find out how much
of the area within 300 meters of industry is residential and how much is green space.
18,180,739.7120 square feet, or 0.65 square, miles is residential. 20,211,314.6820
square feet, or 0.73, square miles is green space. This makes it clear that there is more
green space near industry than residential. To see each land use type, double-click on
Area_total.shp in the TOC. Click Load in the Legend Editor and load landuse.avi,
Click OK. Be sure that DESC is selected as the Field. Click OK, click Apply, and
close the Legend Editor. Uncheck Land_dislvs.shp to turn off its display and move
Parks to the top of the TOC. Now you can see all the land use types as well as the

parks.
Step 17 Save and close the project

From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click Yes to save your changes.
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Self test

{1) Why s it possible for the cutput table of a Union operation to have blank records for some
fields?

e The records for these fields represent features that are present in only one of the input
themes.

e The records for these fields represent features that are present in both of the input
themes.

C The records for these fislds represent new features created by the overlay process.

” The records for these fields are filled in only after the Area, Perimeter, or Length fields
are updated

(2) It's possible to create a buffer around only one feature in a theme?
c True
e False

{(3) If you want to create buffers as multiple rings, you must specify:
e The specified distance representing the total extsnt of the buffer

(& The number of rings and the aftribute field whose values will be used as the distance
between rings

& The distance between rings and the attribute field whose values will be used as the
number of rings

C The number of rings and the distance between them

{4) Unlike theme-on-theme selaction, a buffer operation finds the exact distance from a
feature and draws it in the view.

C True
# False

(5) If you want to create a new theme containing only those features from one theme that fall
within the extent of polygon features in another theme, which operation would you use?

E Intersect

C Clip

e Union

c Theme-on-theme selection

(6) When you use ArcView's geoprocessing tools, ArcView automatically updates the result
theme's area, perimeter, and length fields.

e True
c False
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(7) Which of the following problems must be solved using a buffer?

e Finding the number of hospitals within a 15-mile range of an ambulance station.
C Determining the percentage of cropland within 10 meters of a road.

C Finding the number of nesting sites within a mile of a wolf pack’s territory.

c Finding the number of different land use types within a city's limits.

Suppose you have a point theme that contains three points representing hazardous waste
sites. The theme table has an atftribute fie!d containing the farthest distance away that
contaminants have been found from the sites. How can you map this information?

c Create a buffer using the attribute field to specify the distance between the rings.
c Create a buffer using the attribute field to specify the number of rings.

e Create a buffer using a specified distance.

e Create a buffer using the attribute field to specify the extent of the buffer

Merge can be used to append the features of a theme to those of another theme (or themes),
aven if their feature types (point, line, or polygon) are different.

e True
9 False
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Exercise 6

Creating your data sets

A shapefile theme is actually composed of three files, each of which has the shapefile
name and an extension-.shp (coordinate file), .shx (index file), and .dbf (attribute file).
ArcView uses the information stored in each of the files to draw the theme and
display the theme attribute table.

6.1 Work with shapefiles

Imagine that you are a biologist working for an establishment that protects ecological
biodiversity in the Bahia region of Brazil. Because your establishment's resources are
limited, your job is to target areas for protection to benefit the largest number of
species. You decide to use ArcView GIS to display themes showing the habitats of
various threatened species. By displaying these themes together in a view, you'll be
able to identify which areas have the most species in need of protection. Your
establishment can then concentrate its conservation efforts on these ecological
"hotspots.” Your first task is to create a detailed map of frog habitats in a small
subsection of the Bahia region. To do this, you'll select the features you want to show
from several themes that cover the entire region. Then you'll convert these selected
features to a shapefile and create a new theme.

Estimated time to complete: 20 minutes

Step 1 Start ArcView and load the project

If necessary, start ArcView, then open the project
Introavicreate\lesson01\L01_ex01.apr. When the project opens, you see a view that
contains several themes, including the Bahia region and point themes that show the
habitats of various species. First, you'll select the features for the new theme you want
to create,

Step 2 Select features

Click on the Frogs theme to make it active. Hold down the Shift key and click on the
Bahia theme to make it active as well. Next, click the Draw tool from dropdown list
of tools and select the Draw Rectangle tool. Draw a rectangle on the view where you
see a concentration of frogs. You'll use this rectangle to select features for two new
shapefile themes.

Step 3 Select the features inside the rectangle

Click the Select Features Using Graphic button l The features in both the Frogs
and Bahia themes that lie within or partially within the rectangle are selected and
highlighted in yellow.
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Step 4 Save the selected features to a new shapefile

With the features highlighted, from the Theme menu, choose Coavert to Shapefile.
The Convert to Shapefile dialog displays. Save the shapefile to your c:\temp folder.
In the File Name text box, change the name to frogs2.shp.

Step 5 Save the new shapefile

You're asked if you want to "Add shapefile as theme to the view?" If you answer
No, the selected features are saved in a shapefile but not displayed. If you answer Yes,
the selected features are saved in a shapefile and the shapefile is loaded as a new
theme in the view. Click No.

Step 6 Save the selected Bahia.shp features to a new shapefile

As you did in Step 4, navigate to your c:\temp folder to save the shapefile. In the File
Name text box, change the name to bahia2.shp. Click OK. The Convert to Shapefile
dialog again displays, asking you if you want to add the shapefile to the view. Click
No. The selected features are saved in a shapefile but not displayed.

Step 7 Create a new view and add the shapefiles

Now you'll create a new view and add the shapefiles you just created to the new view.
Make the Project window active and double-click on the Views icon to create a new
view.

Step 8 Add the new shapefiles as themes to the view

From the View menu, choose Add theme. The Add Theme dialog opens. If
necessary, navigate to your c:\temp folder and click once on the bahia2.shp theme to
highlight it. Hold down the Shift key and click on the frogs2.shp theme. Now both
themes are highlighted. Click OK. The themes are added to the new view.

Step 9 Turn on the themes
Tumn both themes on by clicking on their check boxes in the Table of Contents.
ArcView draws the Frogs2.shp and Bahia2.shp themes in the view.

Step 10 Continue to the next exercise
Leave the project open and continue to the next section.

6.2 Edit shapefiles

For this exercise, your task is to create a new shapefile theme showing the areas
where the highest concentrations of endangered species live. To do this, you'll display
themes showing the habitats of endangered species and create a new theme by
drawing polygons around areas that have the most species. Then you'll edit one of the
polygons to make it more accurate.

Estimated time to complete: 25 minutes
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Step 1 Start ArcView and open the project

IfLO1_exOl.apr is open, close Viewl and View3, then open View2 from the project
window. Otherwise, start ArcView if necessary and open the project
introavicreate\lesson01\L01_ex02.apr. When the project opens, you'll see View2
displaying the Bahia region with several species themes. You'll create a new theme
then add shapes to it.

Step 2 Create a new theme

From the View menu, choose New Theme. The New Theme dialog will be
displayed. In the Feature type dropdown list, choose Polygon. Click OK. Another
dialog displays asking you for a theme name.

Step 3 Save the new theme

Save the new theme to your c:\temp folder and name it hotspots.shp. Click OK.

A new theme called Hotspots.shp is added to your view, but it's empty. Next, you'll
add shapes to the new theme. Notice that the check box for the Hotspots.shp theme
has a dashed line around it, indicating that editing is allowed. Before you add features
(shapes) to this theme, you'll specify a new draw symbol.

Step 4 Change the theme's symbol to an outline

Double-click on the Hotspots.shp theme to open the Legend Editor. In the Legend
Editor, double-click on the Symbol to open the Fill Palette. Click on Pattern icon in
the first column of the third row to select it. Now open the Color Palette. In the Color
dropdown list, choose Background. Click on the Transparent color (the white box
in the first row and column with an "X" in it. Click Apply in the Legend Editor. Close
the Symbol Window and Legend Editor. With the new symbol, you'll be able to see
Theme undemeath the shapes you draw.

Step 5 Draw some features

In the Draw tools dropdown list, click the Draw Polygon tool. You will draw three
polygons in the areas with the highest concentration of different species in Bahia.
Click in the view, hold down the mouse button, and drag to create segments of your
first polygon. Each time you click on the view, a vertex is added to the polygon.
Double-click to close the polygon. Use the same procedure to create the other two
polygons. The Hotspots.shp theme now contains three shapes. You've decided that
one of the shapes needs to be edited because it doesn't include all the species habitats
you wanted.

Step 6 Select and zoom to a shape
You'll use the Pointer tool to select a shape and zoom in on it. Click the Pointer tool

then click on the polygon shapes you want to edit. Four selection handles appear

around the shape. Click Zoom to Selected button == to enlarge the selected shape.
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Step 7 Edit the vertices

Click the Vertex Edit tool E. A vertex handle appears at each of the shape's
vertices. Any vertex can be moved to change the shape of the polygon. Move the
Vertex Edit tool over one of the vertices until the mouse pointer changes to
crosshairs. Drag the vertex to a new position. You have just edited the outline of the

shape.

Step 8 Zoom to the extent of the edited theme

Click the Zoom to Active Themes button to display the entire shapefile theme
again. The vertices are still visible, but if you click anywhere outside the shape with
the Vertex Edit tool, they'll disappear.

Step 9 Save your edits

From the Theme menu, choose Stop Editing and click Yes to save your edits. The
changes you made to the polygon are saved in the shapefile. Notice that the dashed
line around the Hotspots.shp check box in the Table of Contents is now gone. This
indicates that the theme is no longer editable. The polygon you just edited is now the
selected feature (highlighted in yellow).

Step 10 Unselect the selected polygon

Click the Clear Selected Features button 3] to unselect the selected polygon.
You've created a new theme containing three polygons that indicate ecological
hotspots, areas where the highest concentrations of endangered species live. In the
next exercise, you'll add attributes to the theme table for each shape you created.

Step 11 Close the project

If you are continuing to the next section now, leave the project open. If you are not
continuing with the next exercise at this time, from the File menu choose Close All.
Again from the File menu, choose Close Project. Click No when you're prompted to
save your changes.

6.3 Add attributes to a shapefile

For each feature you create in a new theme, ArcView adds a record to the theme's
attribute table, But the theme attribute table has only one default field, called Shape,
that's visible. (An invisible field called ID is also added for each record.) In this
exercise, you'll add a new field called Name to the Hotspots.shp theme attribute table
then add values to it. To do this, you'll make the table editable.

Estimated time to complete: 15 minutes
Step I Open the project
If either LO1_exOl.apr or LO1_ex02.apr is open, go to Step 2. Otherwise, start

ArcView if necessary and open the project introavicreate\lesson01\L01_ex03.apr.
When the project opens, you see a view in which the Hotspots.shp theme is active.
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Step 2 Display the theme attribute table

From the Theme menu, choose Table. The Attributes of Hotspots.shp table displays.
The table currently shows one field, Shape. Notice that the Shape field name appears
in italics. This indicates that editing is not allowed. You'll make the table editable.

Step 3 Start editing the table

From the Table menu, choose Start Editing. The Shape field name now appears in
plain text, indicating that editing is allowed. From the Edit menu, choose Add Field.
The Field Definition dialog opens.

Step 4 Create a new field

In the Field Definition dialog, enter Hotspot Name in the Name field. Click Type
dropdown arrow and choose String, then click OK. If a message box appears saying
the field name is too long and ArcView will truncate it, click Yes. A new ficld named
Hotspot Name is added to the table. Next, you'll add values to this field.

Step 5 Select a record

Click on the first record in the table with the Select tool m ArcView highlights the
record in the table and the shape it's linked to in the view. You'll use the Edit tool to
assign a value to the record.

Step 6 Enter record values

Now you'll enter names for the ecological hotspots. Click on the Edit tool . Click
in the first cell in the Hotspot Name field. Type River Basin, then press Enter. The
order of the records corresponds to the order in which you added the shapes. In the
Hotspot field for the second record, type Interior and press Enter. In the Hotspot field
for the third record, type Coastal Plain and press Enter.

Step 7 Stop editing and save edits

From the Table menu, choose Stop Editing. Click Yes when prompted to save your
edits. The field names again appear in italics to indicate that the table is no longer
editable. ArcView saves your changes in the source data file, hotspots.dbf. If you
wanted, you could now build a query using the new attribute field or use it to label the
shapes in the view. The detailed map of frog habitats and the map of hotspots can help
you target those areas most in need of protection. Because both themes are based on
shapefiles, you can edit their features and attributes at any time.

Step 8 Close the project

From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes.
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(9) Which tool do you use fo add features to a new theme?
c Shape tool

o Edit tool

e Theme tool

C Oraw tool

(10) If you add projected data to a projscted view, ArcView will:

c Open the Shapefile Manager so you can specify the projection

& Automatically set the view’'s map and distance units to the units of the projection
e Automatically set the view’s map and distance units to uninown

c Display a waming massage that your data may not display properly

Creating event themes from coordinates files

Sometimes you may have data that is not in a spatial format but does contain feature
location information. You might have, for example, a database of customer addresses,
a table of accident locations based on highway milepost locations, or a file of
endangered species sitings from Global Positioning System (GPS) readings. Can you
use this data in ArcView GIS? Yes. If you have files containing location information
for geographic features or occurrences, you can add them to an ArcView project as
event themes.

6.4 Add event themes

Suppose you're involved in a unique conservation program designed to help
endangered African wildlife and develop local economies at the same time. In this
program, permits are sold to foreign hunters allowing them to hunt in limited numbers
certain species of African wildlife. The money collected from the sale of permits will
go to local villages for building schools and hospitals. In return, villagers agree to
monitor protected areas and prevemt poaching inside these areas. During the last
month, more than 20 antelope have fallen prey to poachers inside protected areas.
You want to know exactly where these incidents took place and in which protected
areas they occurred. You've sent inspectors out armed with portable GPS equipment
to capture precise x,y locations. The x,y locations are measured in decimal degrees
(degrees of latitude and longitude expressed as a decimal), where x is the longitude
and y is the latitude. You've received the data in a dBASE-formatted file.

Estimated time to complete: 20 minutes

Step 1 Open the project

If necessary, start ArcView and open the project
introavicreate\lesson02\L02_ex01.apr. When the project opens, you see a view with
two themes, Villages and Protected Areas. Each village is a point; each protected
area is a polygon defining a conservation unit. There is one conservation unit for each
village. Beyond the Village Protection Areas is a large Federal Protection area. You'll
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bring a dBASE file containing x,y locations into the current project as an ArcView
table.

Step 2 Select a source table

Make the Project window active and click the Tables icon @ then click Add to
open the Add Table dialog. From the List Files of Type dropdown list (in the lower
left part of the dialog), choose dBASE [*.dbf]. This indicates you want to add a table
from a dBASE file. Navigate to introav\create\lesson02 and click on antelope.dbf.

Step 3 Add the source table to the project

Click OK to add the antelope.dbf table to your project. When the table opens, you see
two fields, X_coord and Y_coord. You'll use the location coordinates in these fields to
create a new theme of point features based on ArcView's shapefile format. The table
doesn't need to remain open, so you'll close it first.

Step 4 Open the Add Event Theme dialog box

Close the antelope.dbf table. Make the view active then from the View menu, choose
Add Event Theme. The Add Event Theme dialog displays. At the top of the Add
Event Theme dialog, you see two buttons. Each button represents a category of
events: XY (selected) or Route (clicking a button displays the fields appropriate for
the category chosen). Antelope.dbf is already selected in the Table list. ArcView
reads the field names in this table to find fields likely to contain x,y coordinates. The
names of these fields, X_coord and Y_coord. appear in the X field and Y field lists.

Step 5 Create an event theme

Click OK to create a new theme from the x,y coordinates in the antelope.dbf table.
The new theme, Antelope.dbf, appears in the view's Table of Contents. Click on the
check box next to the theme name to turn it on. ArcView draws the view with the new
theme. Now you can see exactly where the antelope poachings took place. For each
poaching site, you want to know the name of the protected area it's in. To get this
information, you'll perform a spatial join.

Step 6 Open both theme attribute tables

Make both the Antelope.dbf and Protected Areas themes active by holding down the
Shift key and clicking on each theme in the Table of Contents. Click the Open
Theme Table button to open the attribute tables for both themes.

Step 7 Prepare to join the tables

Make the Attributes of Protected Areas table active (this is the source table). Click on
the Shape field name to make it active. Now make the Attributes of Antelope.dbf
table (the destination table) active, and click on its Shape field name to make it
active.

Step 8 Join the tables
With the Attributes of Antelope.dbf table active, [rom the Table menu, choose Join.
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ArcView appends the attributes of each protected area to the poaching sites contained
within it. The Attributes of Antelope.dbf table displays with additional fields
appended from the Attributes of Protected Areas table. For each antelope poaching
site, there is now a name, which is the name of the protected area in which the
poaching incident occurred.

Step 9 Review the results

Now that you know the names of the protected areas where poaching incidents
occurred, you could use the Summarize function to find out how many antelope were
slain in each protected area and which villages need to be more vigilant.

Step 10 Closc the project

From the File menu, choose Close All. Again from the File menu, choose Close
Project. Click No when you're prompted to save your changes. If you are continuing
on to the lesson self test or to the next lesson, leave ArcView running. Otherwise,
choose Exit from the File menu to close ArcView.

6.5 Customizing ArcView’s interface
Menus, buttons and tools in each of the documents of ArcView can be removed or
retained to suit one needs. You will do this in this exercise,

Estimated time to complete: 5 minutes

Step 1 Start ArcView

If necessary, open ArcView and create a project. Highlight View in the project
window and click New. From the View click Properties. Change the name of the
view to Precipitation then Click OK. From the File click Clese All. This will return
you to project window. Create another view and name it Soil. Try to create up to 10
views with different names. When finished, return to the project window.

Step 2 Open Customize dialog box
Double click on any blank part of the button bar. This will display Customize dialog
box.

Step 3 Set customize dialog box properties
Set Type field to View then chose Menus as the Category. Press the Delete button to
remove each View menu except Close All.

Step 4 Change other Categories
Now change the Category to Buttons. Press the Delete button to remove each view
buttons. Repeat the same for Tools.

Step 5 Close View’s window

You‘ll notice that the View interface is now blank. This makes your project to look
tidy. Select and click Close All from the File. This will return you to the Project’s
window. Do not close your project.
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6.6 Writing Avenue scripts

Having completed the customization of your View interface the next step is to write
programs that will allow you to do what you want with the views. You’ll examine
codes written in ArcView Avenue language. You'll also leam how to execute codes
compiled with the language.

Estimated time to complete: 15 minutes

Step I Create a new script form

While you're at the Project interface, click Scripts then New. Click on Seript then
Properties. Type Display_View.training into the Name field. Close the Script
Properties window.

Step 2 Load Avenue codes

A code had been written for you for this exercise. Click on Script then Load Text
File. Now go to \introav\customize\display-view.ave for the file. Press OK.
Examine the code for few minutes before you proceed to the next step.

Step 3 Compile the program
Ready now to compile the program. Compile enables you to check for any syntax

errors in the codes. Click on the Compile tool [Z If you do not get any message, it
means the code has no syntax errors. You can even run the program to be sure it

works. Click on Run button . Go through the program. When you’re satisfied
close the script window.

Step 4 Using the compile code

In most cases you've to attach a compiled code to appropriate medium for use. The
medium can either be Menu, Button or Tool. This code will be attached to Button.
Open Customize dialog box. You did this in Step 2 of last section - Customizing
ArcView’s interface. Set Type field to View then chose Buttons as the Category.
Press the Separator button twice to create blank space. Press the New button to
create new button. Now go down and locate Click fiels. Double click on the space
provided at the right. Script Manager appears. From the Script Manager’s list of
compiled codes scroll to find the code you complied in Step 3 -
Display_View.training. Press OK. Double click for Help. Type in, Opens list of
view available on this project for the Input box that appears and Click OK. Likewise,
double click for Icon. Choose green diamond® then press OK. Close Customize
window.

Step 5 Open view window

Open one of the views you created in the last section. The button you just added will
appear at the button bar. Move the cursor over the button and look down at the status
bar. The text you typed for Help field appears.
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Step 6 Implement the program
Run the program from the View window now. Press the green diamond button. Use
few minutes to implement the program.

Step 7 Close the project
From the File menu click Close all. At the Project window, click File then Close
Project. When prompted to save the project press No.

7.7 Exploring ArcView’s system scripts
The best way to learn Avenue is by looking at the existing Avenue scripts. Some of
the sources of existing Avenue scripts are:

= ArcView Help

= Samples sub-folder in the main ESRI folder

= All ArcView's system scripts for menus, buttons and tool are accessible

Any of these scripts can be copied into the Script Editor window and be modified to
suit one need. You'll alter a system script in this exercise.

Estimated time to complete: 15 minutes

Step 1 Start ArcView
Start ArcView annd with the Views icon selected in the Project window, click the
New button to create a new view.

Step 2 Add a theme
Click the Add Theme button and navigate to \introav\customize and double click on
the Province theme. From the File menu click Close all.

Step 3 Create a new script form
In the project window select the Scripts icon and click the New button.

Step 4 Load script

Click the Load System Script button . You can also do the same by clicking on
Script then Load System Script...

Step 5 Add script to the editor
In the Script Manager dialog box that appears, scroll down to View.Identify. Select it
then click Ok. The script will appear in the Script Editor window.
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Step 6 Add another script

Place the cursor at the end of the script. Click the Load System Scripts button.
Scroll down and select View.ZoomInTool from the Script Manager that appears.
Click OK. The script will be added to end of View.Identify script.

Step 7 Compile the script
Click Compile button to compile the script.

Step 8 Change the name of the script
Select Script then Properties. Type New_Identify.view into the space for the Name
field.

Step 9 Associate the script with a button

Make the view active and double click on an empty part in the button or tool bar to
open the Customize dialog box. Select Views for Type field and Tools for Category
field. Double click on the input space for the Apply field. Select New_Identify.view
from the Script Manager dialog box and press OK.

Step 10 Close the Customize dialog box

Close the Customize dialog box. Open the view. Select the new button you’ve just
added and click on any feature of the theme. The Identify Results dialog box will
appear, the feature will flash, and the view will zoom in to the feature you selected.

Step 10 Close the project

You've just implemented simplest way to make use of existing ArcView's systems
scripts to suit your need. However, in most instances, you may have to alter the code
of the scripts you want to use. Close the project by selecting Close All from the File.
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Select Close Project from the File at the Project window. Do not save the project
when prompted to do so.

Self test

(1) A text filte can be a source for an event table.
@ True
e False

(2) You use the sams dialog to add XY events and linear events.
e True
C False

(3) The event theme attribute table is identical to the event source table.

e True

c False

{(4) Only a line theme can be created from a table containing address information.
c True

c False

(5) You cannot create themes from tables containing only latitude and longitude values.
C

c False

True

(6) ArcView uses the information in an event table to calculate XY locations and then draws
point features at those locations.

c True
e False

(7) You add an event theme by using this dialog.
c Create Events

C New Theme

c Add Event Theme

c Edit theme
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(8) In ArcView, locations stored in a tabular format and used to create theme features are
called:

e XY locators
e Locators
e Events
G Points

(9) Event themes are automatically saved with your project as shapefiles.
E

e False

True

{10) Tables containing the locations of events are called:
* Event tables

c Event theme tables

e Event location tables

c Position tables
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